nvidia 370.23 causes 5 minute delay when switching tty under gnome-shell/mutter 3.21.92 while running an opengl app

To reproduce issue:

  1. Install nvidia 370.23 and gnome-shell/mutter 3.21.91 (or latest
    git).
  2. Open mpv with opengl output. The issue only appears if something is using opengl.
  3. switch to tty. wait 5 minutes while tty appears.

No hang/freeze/delay happens if no opengl app is running.
No relevant messages in dmesg or systemd journal.

To work around issue:

  • Downgrade to 367.44

I have an nvidia bug report generated under 367.44. While it doesn’t
exhibit the problem under that driver, it should give you an overview
of my system. I emailed it to linux-bugs@nvidia.com

I have a 630GT fermi card.

Please take a look before final nvidia 370.xx driver is released.

Just to recap, this issue only happens if something is using opengl (not vdpau).
nvidia-bug-report-367.44.log.gz (58.5 KB)
nvidia-bug-report-370.23.log.gz (57.2 KB)

HussamT, Please attach nvidia bug report of your system.

https://dl.dropboxusercontent.com/u/105616579/nvidia-bug-report-370.23.log.gz (Broken)

https://dl.dropboxusercontent.com/u/105616579/nvidia-bug-report-367.44.log.gz (Working)

Please let me know if you can view the files correctly.

I also tried attaching them to the first post.

Is this happen with any other opengl application like glxgears, mplayer or any things else ? Are playing video with mpv? Any specific video clip/format ?

So far, I have only tried mpv with opengl output (video type is mp4) and opengl games.
When no opengl output, no issue happens.

By the way, the system always recovers. It just pauses for 5 minutes.

@sandipt, by the way, mpv alone with opengl output triggers this bug when there are no other running applications.
Since dmesg and journalctl do not show anything relevant during the 5 minute hang, do you know how else I can get information on what exactly is happening during this 5 minute freeze?
Thank you.

Same issue with 370.28 driver release.

With 367.44 how much delay you observed? Looks issue is very specific to mpv alone with opengl output ? Is any 370 latest driver helped you to resolve the issue? Is this issue happen with Unity, KDE or other desktop env ? have you observed this issue with any other GPU ? Did you tested with any other OS?

  • It is almost instantaneous with 367.44 (no delay what so ever). Timing is usually under a second. 367.44 is an excellent driver release.
  • OpenGL games and mpv with OpenGL output causes this issue under 370.xx drivers.
  • I am using Gnome 3.21.92. I don’t have any other GPU but my 630GT (Fermi).
  • A test case to exhibit the issue is to run the following command while an opengl game or mpv is running:
    xrandr --nograb --output HDMI-0 --off ; xrandr --output HDMI-0 --preferred
    This cause random freezing for 3 to 5 minutes. (On 367.44, it turns off and lights up immediately. On 370.xx, it turns off and freezes)
  • Both 370.23 and 370.28 show this issue (If there are other 370.xx releases that I can test, please give me a link and I can test).

In addition:

  • glxgears also causes this issue with 370.xx driver. It is not just mpv.
  • no issue with VT switching in 367.44 driver while running glxgears.

One note of interest, gnome-shell/mutter 3.21.xx adds support for NV_robustness_video_memory_purge.

I bought a msi 730 GT. Same issue there, GK208 (Kepler architecture).

  • With 370.xx driver, glxgears breaks VT switching.
  • With 367.44 driver, VT switching is instantaneous with with glxgears running.

Sandipt, any idea what I can do in this situation, please?
Any more information I can provide to help debug this issue?
Thank you.

I reproduced what I’m pretty sure is the same problem and I’m working on getting a fix in for the release 375 driver series.

Ok, thank you very much.

Tracking this issue under 200237604