Bug in 515.65.01 - Mouse/Keyboard Delay of 2+ Seconds

There is an initial 2+ second delay responding to the mouse, keyboard or touchpad, on clean installs of Ubuntu 22.04.1 on three laptops:

Asus ROG Zephrus: AMD Ryzen 9 + RTX 3060
Lenovo Legion 5: AMD Ryzen 7 + RTX 3050Ti
Gigabyte G5: Intel i5 + RTX 3060

The delay begins after adding “PrimaryGPU” “Yes” to /usr/share/X11/xorg.conf.d/10-nvidia.conf

The delay stops as long as there is input activity, but after 10 or so seconds of inactivity, the initial delay returns.

If nvidia-settings is opened and GPU-0 is selected, the delay stops!
If anything not under GPU-0 is selected, the delay returns.
If nvidia-settings is closed, the delay returns.

Setting PowerMizer to Adaptive or Performance does not help.

However, adding the following to ~/.xinitrc eliminates the delay, but must be set to Performance (1), which locks the GPU at full bore Level 3, essentially eliminating PowerMizer:

nvidia-settings -a “GPUPowerMizerMode=1” &
. /etc/X11/xinit/xinitrc

This behavior is readily repeatable on all three laptops, but does not appear on two desktops (Ryzen and Xeon) with GTX’s which do not have integrated GPU’s.

A solution would be greatly appreciated.

Please set kernel parameter
nvidia-drm.modeset=1
Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (237.7 KB)

nvidia-drm.modeset=1 was set in /etc/modprobe.d/nvidia-graphics-drivers-kms.conf

I also set GRUB_CMDLINE_LINUX_DEFAULT=“nvidia-drm.modeset=1” but no change.

UPDATE: Identical behavior with a fresh Linux Mint 21/515.65.01 install on a Gigabyte G5: Intel i5 + RTX 3060.