Slow terminal after upgrading into the newest propietary NVIDIA graphics driver

I’m using an rtx 3090 ti on an Ubuntu 22.04.4 LTS, I was using the ‘nvidia-driver-535’ which is the one my system recommended me to install; Everything was going fine until I saw a new upgradable version of those drivers were available to install, I used the command ‘sudo apt-get full-upgrade’ to install them.
From that moment I see that every time I type in the terminal the input keys I press delays half of a second to be written, alongside with some weird artifacts appearing on the letter I just write (artifacts that becomes more obvious when there are more characters being changed in the terminal at the same time, such as in the program ‘glances’ which looks to have some kind of “flickering” in the moment of updating the info displayed in it ).
Apart from that the drivers look to work fine, I’m working on a GPU-HPC project which didn’t see affected in performance, and the firefox browser doesn’t seem to have that input key delay problem.
I’m sure this is caused by the mentioned drivers because the problem disappear when I remove all drivers (With ‘sudo apt-get remove --purge ‘^nvidia-.*’’) and let the system with the default/‘out of the box’ drivers, and the problem comes back when I reinstall them.

I would like to know if there is any solution for this problem, due to I haven’t found any similar report like mine neither in Ubuntu forums nor in this one.

Thanks in advantage and I know I haven’t bring any additional data than the OS version and the GPU I’m using since I don’t have any clue on what may be causing this issue, feel free to ask any extra info you need to figure out what is happening.

1 Like

This started happening to me too.

Mutter has a bug and they fixed it. However after applying the fix the lag got a little better but it didn’t go away.

I have tired the latest mutter with various nvidia driver with no luck the lag goes away initially but after a undetermined time creeps up on you.


Many thanks for your response.
It looks it wasn’t because of NVIDIA drivers after all, it also looks that the issue is brand new and there is some people trying to solve it.
Thanks for sharing the thread, I’ll keep an eye on it waiting for an official fix.


I have the exact same problem. Tried switching to xfce terminal and it appeared to be free of the issue - at first. After an hour or so, it started having the same problem as the default terminal. Now it’s just as bad.

I will type something out and hit TAB to make it auto-complete - and it just ignores me until I press TAB again. And it’s not just TAB. A lot of times it ignores ENTER. Sometimes it takes the keystroke after a delay. Sometimes it even inserts it’s own ketstrokes. For example, I use minicom to collect serial debug from devices. After a few uses of minicom, I type the hotkey to exit → ctrl A, then Z, then X to exit, and the usual popup of “do you really want to exit” comes up and I press ENTER for “yes”, and every time, it LITERALLY moves my selection to “no”, and selects that, and therefore minicom won’t close! It’s as if ENTER has become right-arrow + enter! Like a ghost intercepted my keystroke, pressed the right arrow to select “no”, and THEN presses enter. Am I being pranked?

And it’s ONLY terminal. Both the default terminal that comes with ubuntu and xfce have this problem. No other app does this. Only terminal. BUT… I have seen the weird video behavior too. I’ll try to describe it…

One time I was copy-pasting between terminal and the default text editor. When I pasted something into the terminal, the text in the text editor started “flashing” at the same rate as the cursor in the terminal. It would like, highlight and un-highlight in sync with the terminal’s blinking cursor. So strange!

And this sucks because I switched to the nvidia driver because the nouveau kept crashing on me. The nvidia driver (in performance mode) is much smoother than the nouveau driver and doesn’t crash. I kinda need it, but my terminal experience has been almost wrecked. Please fix!

Anything I can provide to help? Logs? Dumps?

Switching to wayland appears to have worked around the problem for me. Only drawback is that the video performance is not great. In xorg the mouse and window movements are smooth (with the “Performance Mode” profile set in nvidia settings). In wayland, the movements are a bit choppy even in performance mode.

But it’s not bad enough to slow me down or annoy me. As long as everything behaves I can be happy enough with this. I use this pc for work (firmware dev) so don’t need superb graphics. Will definitely keep an eye out for a fix and switch back to xorg to get the performance back when it’s available. Hopefully this helps someone in the meantime.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.