NVIDIA and 4k screen under ubunutu

I am facing a problem when connecting a ASUS 4k screen to my DELL Latitude E7450 running on ubuntu 16.04 (unity).

I have a “bumblebee-like” setup with: An integrated Intel and an NVIDIA GM108M (GeForce840M)

Initially, only the Intel graphic card was used and I could connect my screen up to resolution, 2560x1600 (16:9) and the image is obviously distorted and a little blurry. After that when trying in 4k (3840x2160 (16:9)), I would just get a black screen with the message: no signal.

My screen is connected via a display port 1.2 to a dell docking station.

I installed NVIDIA Prime and allowed ubuntu to only run using NVIDIA drivers (this holds when rebooting the computer and having the screen plugged in. At some point it was only working if booting and plugging-in the screen afterwards …).

I have tried with several drivers for NVIDIA: 367, 331 and 361. 331 does not work at all while 361 and 367 provide the same result. The result being that I can see my screen in 4k display (60Hz) but it is flickering. The top part of the screen is pretty stable and as you go down it shake more and more (tracking/recognition issue).

Suggestions?

Thank you for your eventual support!

I’d highly suggest upgrading your drivers. I believe there is an Ubuntu graphics drivers PPA, I think I’ve used it on another install but I’m on Arch so not 100% sure. You can find their launchpad site here https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa. That may be easier to maintain than the official release here, obviously your choice.

It looks like the current best bets are either the 375.39 or 378.13 driver releases. Double check the supported hardware before installing!

Here’s an automated driver selection tool from NVidia http://www.geforce.com/drivers. I’ve used that countless times to double check before installing.

The README for the 375.39 release http://us.download.nvidia.com/XFree86/Linux-x86/375.39/README/supportedchips.html lists your hardware - the URL is the same format for any other related release, just swap out the version.

After several years and many long hours in similar situations I’ve learned that the first step is to make sure you’re on the latest drivers, which arguably can be a challenge on Ubuntu as they tend to have a longer testing phase before they release. If the problem still exists then at least you’ve narrowed down the easy stuff first before spending more time on it.

Either way, check back in with your results so that anyone else can benefit from the feedback. : ) Good luck!

Cheers –