Bug with Linux Driver & Acer XB280HK 4K Gsync Monitor

Hi guys, I’ve encountered a bug with Linux drivers and my Monitor which I thought I’d share here.

If I change my drivers from Nouveau to Nvidia Proprietary on Ubuntu 15.10 then I am unable to change from 4K resolution in anything. Unitys Settings page only shows 3840x2160 as an option and most games also only show that resolution as an option. In games where I can change the res, when I do change it doesn’t scale to refit to screen so I only see the corner of the screen with 3 quarters of it missing.

If I open up Nvidia X Server Settings I am given a lot more choice in resolution but they all say (Scaled) next to them except for 4K and if I choose one the screen goes really blurry and I can scroll the desktop into whitespace by moving the mouse cursor to the edge of the screen.

In Windows this display functions perfectly at 1080i, 1080p, 1440p and UHD/4K so it has to be a Linux bug.

I’m 99% sure this is an Nvidia Driver bug as if I select Nouveau in the Additional Drivers screen I am able to swap between all available modes with no issues at all however then Steam refuses to work without issuing a terminal command every time I launch it and a lot of games simply refuse to run.

I have

I7 6700K
MSI Z170A Gaming M7
MSI GTX970 Gaming 4G
16GB DDR4
SSDs
Acer XB280HK 2K4K Gsync
Ubuntu 15.10 running latest driver from Additional drivers page (352.41)

For reference I have also tried uninstalling Nouveau entirely and then installing the latest Binary from the Nvidia Driver website but the outcome is still the same. Also running the Updates driver has the same outcome too.

Please help/advise.

Heres the xorg.0.log - http://pastebin.com/2gVHxusj
Heres lspci -v - http://pastebin.com/mQECpUZ1

If thers anything else you need let me know.

Thanks.