Nvidia driver installation for GTX 1060 Max-Q Design 6GB fails on Scientific Linux 7.4

Hi all! I have a problem with installing Nvidia driver on my OS Scientific Linux 7.4 and hope I can find a way to solve it here.
I have a dell gaming inspiron 7577 with GTX 1060 Max-Q Design 6GB. The following steps are what I did after successfully installing Scientific Linux 7.4 and verifying some stuffs according to pre-installation actions.

yum install epel-release

yum install dkms

yum install cuda-repo-rhel7-9-1-local-9.1.85-1.x86_64.rpm (md5 is correct)

yum clean expire-cache

yum install cuda

Those steps are exactly what this link shows me: http://docs.nvidia.com/cuda/cuda-installation-guide-linux/index.html. I saw that the driver package 387.26 was installed automatically.
Everything seemed to be fine until rebooting. The screen was stopped on this line “Stared Crash recovery kernel arming”. I tried some ways in some topics in this forum to fix it but nothing changed. I wonder if that driver supports my graphics card.
Any supports appreciated. Thanks.

Scientific Linux is not an officially supported distro for CUDA

instead of this rpm(local):

# yum install cuda-repo-rhel7-9-1-local-9.1.85-1.x86_64.rpm (md5 is correct)
                                  ^^^^^

try using the rpm(network) rpm installer (from http://www.nvidia.com/getcuda)

Nothing changed! I think the problem is the way I installed Nvidia driver on my Nvidia Optimus laptop run SL 7.4. It might be wrong. Do you know a properly way to do that?

Hi txbob. Using network-rpm didn’t change anything. But I could get it run perfectly with using bumblebee package. Finally problem has been solved. Thank you for great help.