NVIDIA Driver NVIDIA-Linux-x86_64-340.107 Kernel bigger than 5.1.12-1

Hello,

i am running Suse LEAP 15.1 on a Lenovo T510 Notebook.
I have installed NVIDIA-Linux-x86_64-340.107 with patches for Kernel 5.0 and 5.1.
Everything works fine until Kernel 5.1.11-2.
From kernel 5.1.12-1 until now 5.1.15-7 the state is: I can compile and install the
driver without errors but after reboot i have only a black screen.
Ich cannot schwitch to virtual consoles.
The notebook is still reachable via ssh.

Is there a new patch existing ?

kind regards

Ulli
nvidia-installer.tar.gz (21.5 KB)

Ulrich,

I can’t help you but on my 2007 Dell inspiron 1720 laptop on Kubuntu 19.04 (KDE plasma 5.15.4) I have been able to install NVIDIA-Linux-x86_64-340.107 with kernel 5.0 and 5.1 patches from https://pkgs.rpmfusion.org/cgit/nonfree/nvidia-340xx-kmod.git/log/ (I had to fix one of the patches myself) with ubuntu’s mainline kernel 5.1.16.
I also had to extract the *custom.run to disable compiling of uvm (dkms.conf and Makefile).

Hallo,
thank you for yor answer.

Can you tell me what you have changed in dkms.conf and in the Makefile (which Makefile).
I removed everything that contains “uvm” but can no more compile the driver.

kind regards
Ulli

My apologies, Ulrich, for not answering sooner but the last days were very busy and too hot with the heat wave.

To not load nouveau I created /etc/modprobe.d/blacklist-nouveau.conf :
blacklist nouveau
options nouveau modeset=0

In one of the 2 patch files I changed “+++ b/kernel/nv_time.h” to “+++ kernel/nv_time.h” so it would show up alright in the kernel folder (the --apply-patch parameter of the nvidia .run file should get fixed).

bash NVIDIA-Linux-x86_64-340.107.run --apply-patch buildfix_kernel_5.0_fix_nv-time.patch
./NVIDIA-Linux-x86_64-340.107-custom.run --list | more
bash NVIDIA-Linux-x86_64-340.107-custom.run --apply-patch xf86-video-nvidia-legacy-02-fix-linux-5.1.patch

extract the custom.run

In file .manifest I had to add nv_time.h

In the kernel folder I did not change the Makefile (it has “nv_uvm_interface.c” in it but no need to remove that as that is not the uvm module).
In the dkms.conf in the kernel folder I commented out the lines for uvm to:

#BUILT_MODULE_NAME[1]="{PACKAGE_NAME}-uvm" #BUILT_MODULE_LOCATION[1]="uvm/" #DEST_MODULE_LOCATION[1]="/kernel/drivers/video" #MAKE[0]+="; make -C uvm module KERNEL_UNAME={kernelver} KBUILD_EXTMOD={dkms_tree}/{PACKAGE_NAME}/{PACKAGE_VERSION}/build/uvm" #CLEAN+="; make -C uvm clean" #BUILT_MODULE_NAME[1]="{PACKAGE_NAME}-uvm"
#BUILT_MODULE_LOCATION[1]=“uvm/”
#DEST_MODULE_LOCATION[1]="/kernel/drivers/video"
#MAKE[0]+="; make -C uvm module KERNEL_UNAME={kernelver} KBUILD_EXTMOD={dkms_tree}/{PACKAGE_NAME}/{PACKAGE_VERSION}/build/uvm"
#CLEAN+="; make -C uvm clean"

In the uvm folder I moved the files dkms.conf.fragment and Makefile to unusable files (not sure if this was really necessary):
mv Makefile donotbuilduvmMakefile
mv dkms.conf.fragment donotusedkms_conf_fragment

running then “sh ./nvidia-installer” (in a root shell of course, not with X running) when it’s building it gives an error “unable to open ‘kernel/uvm/Makefile’ for copying” but it asks “would you like to continue installation anyway?”
and the nvidia kernel module then got installed.

Then I did a update-initramfs -u -k on the 5.1.16, I don’t know what command for that is used in SUSE.

Dear vatbier

I am using SuSe TW Linux 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) i686 i686 i386 GNU/Linux means 32 bit and tried above mentioned patches.
Nouveau is blacklisted and not loaded during install.

The 340.107 Driver then compiled w/ --no-unified-memory and did not include DKMS in menu-install.
The machine starts in 5.2 but screen stays black, Xorg.0.log stating “no screen found”.
Am I missing any configuration ?

Same patched driver runs w/ 4.20.6-1-default #1 SMP Thu Jan 31 07:37:50 UTC 2019 (463cfd2) i686 i686 i386 GNU/Linux w/o problem.

See below the Xorg.0.log

Thanks, Freddy

PS https://devtalk.nvidia.com/default/topic/1061817/linux/340-107-patch-for-linux-kernel-5-2/post/5376873/#5376873 maybe same question

[ 13.597] (–) Log file renamed from “/var/log/Xorg.pid-1830.log” to “/var/log/Xorg.0.log”
[ 13.598]
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[ 13.598] Build Operating System: openSUSE SUSE LINUX
[ 13.598] Current Operating System: Linux chimera3.homesite 5.2.11-1-default #1 SMP Thu Aug 29 06:41:19 UTC 2019 (6385110) i686
[ 13.598] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.2.11-1-default root=UUID=3a2095f0-d479-4bcd-933e-899906ff64f6 resume=/dev/sda1 splash=silent quiet nomodeset showopts
[ 13.598] Build Date: 30 August 2019 12:00:00PM
[ 13.598]
[ 13.598] Current version of pixman: 0.36.0
[ 13.598] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 13.598] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 13.598] (==) Log file: “/var/log/Xorg.0.log”, Time: Fri Oct 4 12:49:00 2019
[ 13.611] (==) Using config file: “/etc/X11/xorg.conf”
[ 13.611] (==) Using config directory: “/etc/X11/xorg.conf.d”
[ 13.611] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
[ 13.617] (==) ServerLayout “Layout0”
[ 13.617] (
) |–>Screen “Screen0” (0)
[ 13.617] () | |–>Monitor “Monitor0”
[ 13.618] (
) | |–>Device “Device0”
[ 13.618] () |–>Input Device “Keyboard0”
[ 13.618] (
) |–>Input Device “Mouse0”
[ 13.618] (==) Automatically adding devices
[ 13.618] (==) Automatically enabling devices
[ 13.618] (==) Automatically adding GPU devices
[ 13.618] (==) Max clients allowed: 256, resource mask: 0x1fffff
[ 13.628] (WW) The directory “/usr/share/fonts/misc/sgi” does not exist.
[ 13.628] Entry deleted from font path.
[ 13.629] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/ghostscript/,
/usr/share/fonts/cyrillic:unscaled,
/usr/share/fonts/truetype/,
built-ins
[ 13.629] (==) ModulePath set to “/usr/lib/xorg/modules”
[ 13.629] (WW) Ignoring unrecognized extension “XFree86-DGA”
[ 13.629] (WW) Hotplugging is on, devices using drivers ‘kbd’, ‘mouse’ or ‘vmmouse’ will be disabled.
[ 13.629] (WW) Disabling Keyboard0
[ 13.629] (WW) Disabling Mouse0
[ 13.629] (II) Loader magic: 0x6966a0
[ 13.629] (II) Module ABI versions:
[ 13.629] X.Org ANSI C Emulation: 0.4
[ 13.629] X.Org Video Driver: 24.0
[ 13.629] X.Org XInput driver : 24.1
[ 13.629] X.Org Server Extension : 10.0
[ 13.630] (++) using VT number 7

[ 13.630] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[ 13.634] (–) PCI:*(1@0:0:0) 10de:06e1:1acc:853d rev 161, Mem @ 0xfd000000/16777216, 0xd0000000/268435456, 0xfa000000/33554432, I/O @ 0x0000cc00/128, BIOS @ 0x???/131072
[ 13.634] (–) PCI: (2@0:0:0) 14f1:8880:0070:f038 rev 4, Mem @ 0xfe800000/2097152
[ 13.634] (II) LoadModule: “glx”
[ 13.642] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[ 13.731] (II) Module glx: vendor=“NVIDIA Corporation”
[ 13.731] compiled for 4.0.2, module version = 1.0.0
[ 13.731] Module class: X.Org Server Extension
[ 13.731] (II) NVIDIA GLX Module 340.107 Thu May 24 21:47:46 PDT 2018
[ 13.731] (II) LoadModule: “nvidia”
[ 13.735] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[ 13.750] (II) Module nvidia: vendor=“NVIDIA Corporation”
[ 13.750] compiled for 4.0.2, module version = 1.0.0
[ 13.750] Module class: X.Org Video Driver
[ 13.753] (II) NVIDIA dlloader X Driver 340.107 Thu May 24 21:24:47 PDT 2018
[ 13.753] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 13.801] (II) Loading sub module “fb”
[ 13.801] (II) LoadModule: “fb”
[ 13.801] (II) Loading /usr/lib/xorg/modules/libfb.so
[ 13.803] (II) Module fb: vendor=“X.Org Foundation”
[ 13.803] compiled for 1.20.5, module version = 1.0.0
[ 13.803] ABI class: X.Org ANSI C Emulation, version 0.4
[ 13.803] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 13.803] (II) Loading sub module “wfb”
[ 13.803] (II) LoadModule: “wfb”
[ 13.803] (II) Loading /usr/lib/xorg/modules/libwfb.so
[ 13.804] (II) Module wfb: vendor=“X.Org Foundation”
[ 13.804] compiled for 1.20.5, module version = 1.0.0
[ 13.804] ABI class: X.Org ANSI C Emulation, version 0.4
[ 13.804] (II) Loading sub module “ramdac”
[ 13.805] (II) LoadModule: “ramdac”
[ 13.805] (II) Module “ramdac” already built-in
[ 13.811] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[ 13.811] (EE) NVIDIA: system’s kernel log for additional error messages and
[ 13.811] (EE) NVIDIA: consult the NVIDIA README for details.
[ 13.811] (EE) No devices detected.
[ 13.811] (EE)
Fatal server error:
[ 13.811] (EE) no screens found(EE)
[ 13.811] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 13.811] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
[ 13.811] (EE)
[ 13.911] (EE) Server terminated with error (1). Closing log file.