NVIDIA GeForce GT 710 driver 470 fails to load and doesn't recognize native resolution nor second monitor in XUbuntu 20.04

Hello. Recently I’ve been experiencing problems with the drivers for XUbuntu 20.04, although it has been working properly until today. I have the Linux Kernel 5.4.0-100, a NVIDIA GeForce GT710 card and using the 470 version of the driver.

I’ve already tried purging all the versions, reinstalling them, rebooting…Also tried to include the “pci=realloc” parameter on grub, and tried to use an older driver version without success. This is the bug report log:
nvidia-bug-report.log.gz (84.5 KB)

Thanks in advance!

Edit: Secure Boot does not apply for my computer

Please try loading it manually
sudo modprobe nvidia
and post any errors.

Trying to run sudo modprobe nvidia gives me this error:

modprobe: ERROR: could not insert 'nvidia': Unknown symbol in module, or unknown parameter (see dmesg)

dmesg outputs this:

[ 2144.633834] nvidia: Unknown symbol drm_gem_object_put_unlocked (err -2)

Your system compiler is set to gcc 8.4 but should be 9.3. Please set the correct compiler, then reinstall the driver.

I tried that, with no success sadly.

Tried sudo apt install gcc-9; to ensure it was already installed and it was. Then:

sudo update-alternatives --remove-all gcc;
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-9 10;
sudo update-alternatives --install /usr/bin/cc cc /usr/bin/gcc-9 10;
gcc --version;

Which outputs the gcc version 9.3 correctly.

I also made sure to double and triple check the remaining nvidia files after purging, and two files remained even after purging: libnvidia-compute-470:i386 and libnvidia-compute-390:i386. I removed them manually and reinstalled everything, with no success

Does modprobing it still reports the same error?

Yes, it does report the same error as the previous message

Please try reinstalling the headers
sudo apt install --reinstall linux-headers-$(uname -r)

Done, without success either

I get the feeling dkms doesn’t replace the modules. Please post the output of
dkms status

It outputs this:

nvidia, 470.103.01, 5.4.0-100-generic, x86_64: installed

Please run
sudo dkms remove nvidia/470.103.01
sudo dkms install nvidia/470.103.01
afterwards, please attach the make log

Here it is:
make.log (1.0 MB)

I only now noticed that the whole drm.ko module is missing in your system, so the nvidia driver is correctly compiled but the module is missing. Please try reinstalling the linux-modules and linux-modules-extra packages and check if lsmod |grep drm shows it.

It worked perfectly! That was the problem. Upon reinstalling the modules for my kernel version and rebooting, now both screens are working properly. lsmod | grep drm shows the modules correctly.

Thanks a lot for your help and time!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.