Nvidia Grid 1 vGPU Driver for Ubuntu Guest OS


I am have an Nvidia M6 Grid K1 that I am sharing its GPU on multiple Ubuntu 14.04 VMs running on VMware Horizon view 6.2.

At the VM terminal, the command “lspci” shows me this message:

[b]VGA compatibility controller: VMware SVGA II Adapter

VGA compatibility controller: NVIDIA Corporation GK107GL [GRID K140Q vGPU] (rev 01)[/b]

I have the VMs configured with Grid K180Q on the vSphere Web client as shown in your Nvidia Grid documentation:

But, still it is showing Grid 140Q for the vGPU. I have tried to change it to 160Q and it is always showing 140Q.

Also, I have tried to install all the Nvidia available driver for Linux with the once personalized for Ubuntu 14.04 from the package repository “ppa:xorg-edgers”. But still I always get the same issue, as if I have no Nvidia graphical card installed on the VM when I run “nvidia-detector” command.

I have also noticed that the driver name used on your documentation has the word “grid” at its end. I couldn’t find any driver wth that name. Following the documentation I should find the driver at the zip file “NVIDIA-GRID-vGPU-kepler-vSphere-2015-352.70-354.56.zip”. But I can only get the following files:

    352.70-354.56-nvidia-grid-vgpu-release-notes.pdf 352.70-354.56-nvidia-grid-vgpu-user-guide.pdf 354.56_grid_kepler_win10_64bit_international.exe 354.56_grid_kepler_win10_international.exe 354.56_grid_kepler_win8_win7_64bit_international.exe 354.56_grid_kepler_win8_win7_international.exe NVIDIA-vGPU-kepler-VMware_ESXi_6.0_Host_Driver_352.70-1OEM.600.0.0.2494585-offline_bundle.zip NVIDIA-vGPU-kepler-VMware_ESXi_6.0_Host_Driver_352.70-1OEM.600.0.0.2494585.vib

I can clearly see the Windows 7, 8 and 10 drivers with the ESXI driver but the Linux Guest OS Driver for Grid I can’t find it.

Finally, there is the licensing part. Are we supposed to have a license the moment we buy the hardware, or we can buy it later?

It would be really helpful if you can point from where I can download that driver or is there any other way to fix the issue. Many thanks.

Kind regards,


You could tell me how you installed your GRID licenses, I have a problem with the installation, in the same way it runs a vm ware esxi 6.0 and a linux, I want to run them in 4 virtual machines and I have to make a virtual machine dedicated to nvidia 5, the use I’m going to make is for graphic accelerators,

I would appreciate your help in this problem


Apologies, this topic should be removed. It was a misunderstanding that I have made trying to sort out how NVIDIA and VMWARE work together. Bottomline, there is the configuration to use to set up an NVIDIA card for virtualisation/GRID usage: vGPU, vDGA, and sVGA.

  • vGPU: Average/decent performance, fully automated. It allows you to share GPU resources between multiple VMs automatically-ich.
  • vDGA: The highest performance that you can get out of your GPU card, Needs manual or scripted setup. It links the physical GPU to a VM.
  • sVGA: The lowest performance, fully automated and rely on the VMware tools for the VM to use and GPU power

That is me explaining what you may already know. I was using an NVIDIA GRID K1 to run mainly Linux VMs on VMware environment. I needed max performance, same as your case, so as a smart-ich guy, I have opted for vDGA, scripted, using PowerShell and PowerCLI, my way through it to get as automated as possible to deploy VMs and link them with GPUs using vDGA.

So to be able to help you, I need to know two things: what is an NVIDIA 5? and what NVIDIA Tesla or GRID card are you using (You can check this by using your Windows vSphere Client, click on the ESXi host -> Configuration -> Advanced Settings)?

Bare in mind, NVIDIA has changed it licencing (http://images.nvidia.com/content/grid/pdf/161207-GRID-Packaging-and-Licensing-Guide.pdf) Using Linux VMs you can only use vDGA which is an option only available on their most expensive licencing option “Quadro Virtual Datacenter Workstation”. But if you are one of the lucky few and you own a GRID K1 you can use vDGA without a licence.

I hope that was helpful, please let me know if you need extra details.

Kind regards,