nVidia Quadro P2000 not working

I just purchased a dell 5530 precision laptop running on ubuntu 18.04.2 LTS OS. It was shipped with a nVidia Quadro P2000 card as per specs in https://www.dell.com/support/home/ca/en/cadhs1/product-support/servicetag/68401x2/configuration.

However, the device is not working on my computer. I have downloaded and tried installing the latest driver from https://www.nvidia.com/Download/driverResults.aspx/148435/en-us but that gave an error message that “The distribution provided pre-install script failed”. Has anybody been able to navigate this challenge. I have contacted dell but they suggested I contacted NVIDIA for help with the issue.

Thanks.

Please follow this:

Hi there,

Thanks for your response.
I add the ppa and tried installing but I’m getting the following messages about some missing dependencies:

“The following packages have unmet dependencies:
nvidia-driver-430 : Depends: libnvidia-gl-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-dkms-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-kernel-source-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-decode-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-encode-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-utils-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: xserver-xorg-video-nvidia-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-cfg1-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-ifr1-430 (= 430.26-0ubuntu0~gpu18.04.1) but it is not going to be installed
Recommends: libnvidia-decode-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-encode-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-ifr1-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-fbc1-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-gl-430:i386 (= 430.26-0ubuntu0~gpu18.04.1)
E: Unable to correct problems, you have held broken packages.”

Odd. Please check if the 418 driver installs:
sudo apt install nvidia-driver-418

Hi there,

That doesn’t seem to resolve the issue. The messages I’m getting now are :

"Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-driver-418 : Depends: libnvidia-gl-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-dkms-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-kernel-source-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-decode-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-encode-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: nvidia-utils-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: xserver-xorg-video-nvidia-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-cfg1-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-ifr1-418 (= 418.56-0ubuntu0~gpu18.04.1) but it is not going to be installed
Recommends: libnvidia-decode-418:i386 (= 418.56-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-encode-418:i386 (= 418.56-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-ifr1-418:i386 (= 418.56-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-fbc1-418:i386 (= 418.56-0ubuntu0~gpu18.04.1)
Recommends: libnvidia-gl-418:i386 (= 418.56-0ubuntu0~gpu18.04.1)
E: Unable to correct problems, you have held broken packages."

How did you add the ppa?
You can also use the Software&drivers application to install a driver from the Ubuntu repo.

sudo add-apt-repository ppa:graphics-drivers/ppa

Sorry, I missed your answer.
Did you already try to run
sudo apt update
sudo apt upgrade
after adding the ppa to make sure sources and system are updated?

Fails for me as well
I ran

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
apt list --upgradable

However, when running the command to install the latest driver, it failed
(base) volk@volk-Precision-5530:~$ sudo apt install nvidia-driver-430
Reading package lists… Done
Building dependency tree
Reading state information… Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
nvidia-driver-430 : Depends: xserver-xorg-video-nvidia-430 (= 430.40-0ubuntu0~gpu18.04.1) but it is not going to be installed
Depends: libnvidia-cfg1-430 (= 430.40-0ubuntu0~gpu18.04.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My configuration
(base) volk@volk-Precision-5530:~$ sudo ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001CBAsv00001028sd0000087Dbc03sc02i00
vendor : NVIDIA Corporation
driver : nvidia-driver-410 - third-party free
driver : nvidia-driver-415 - third-party free
driver : nvidia-driver-390 - third-party free
driver : nvidia-driver-430 - third-party free recommended
driver : xserver-xorg-video-nouveau - distro free builtin

my system Ubuntu 18.04.2 LTS