Nvidia Quadro P1000 - repo nvidia-driver-430 not running

I have fresh install of Ubuntu 18.04.2

First problem I have noticed was very “laggy” login screen (gdm3) so I switched to lightdm and that works normally.

Then I installed nvidia drivers from the repo by:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
ubuntu-drivers devices

which returned this:
== /sys/devices/pci0000:3a/0000:3a:00.0/0000:3b:00.0 ==
modalias : pci:v000010DEd00001CB1sv0000103Csd000011BCbc03sc00i00
vendor : NVIDIA Corporation
model : GP107GL [Quadro P1000]
driver : nvidia-driver-396 - third-party free
driver : nvidia-driver-430 - third-party free recommended
driver : nvidia-driver-410 - third-party free
driver : nvidia-driver-415 - third-party free
driver : nvidia-driver-390 - distro non-free
driver : nvidia-driver-418 - third-party free
driver : xserver-xorg-video-nouveau - distro free builtin

Then I typed:
sudo apt install nvidia-driver-430
sudo reboot

When system booted I tried:
sudo nvidia-smi

which returned:
Mon Jun 3 16:06:52 2019
| NVIDIA-SMI 430.14 Driver Version: 430.14 CUDA Version: 10.2 |
| GPU Name Persistence-M| Bus-Id Disp.A | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 Quadro P1000 Off | 00000000:3B:00.0 Off | N/A |
| 34% 37C P8 N/A / N/A | 0MiB / 4040MiB | 0% Default |

| Processes: GPU Memory |
| GPU PID Type Process name Usage |
| No running processes found |

Then I typed:

which gives:
ERROR: Unable to load info from any available system

(nvidia-settings:4481): GLib-GObject-CRITICAL **: 16:07:22.787: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 16:07:22.792: PRIME: No offloading required. Abort
** Message: 16:07:22.792: PRIME: is it supported? no

Then I typed:
sudo prime-select nvidia (btw this returned: Info: the nvidia profile is already set)
sudo reboot

I also checked if secure boot is disabled and it was,but the nvidia-settings command still gives me the same error.
I did not touch anything else in the system.

What am I missing?
Thank you.

nvidia-bug-report.log.gz (1.12 MB)

The xserver is running on the integrated ASPEED server graphics.
Please create /etc/X11/xorg.conf with contents

Section "Device"
    Identifier     "nvidia"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BusID          "PCI:59:0:0"
    Option         "AllowEmptyInitialConfiguration"

then connect the monitor to an output on the nvidia card and reboot.

Thanks for the quick answer.

The displays are working properly now and nvidia-settings command behaves normally as well.

Part of the message still appears after nvidia-settings command though:

(nvidia-settings:2871): IBUS-WARNING **: 17:23:58.613: The owner of /home/username/.config/ibus/bus is not root!
** Message: 17:23:58.962: PRIME: No offloading required. Abort
** Message: 17:23:58.962: PRIME: is it supported? no

But that is not problem right?

No other problems seems to manifest themselves so far.

Thank you.

Those messages are expected with your setup (ASPEED gpu + Nvidia gpu), just ignore.