Nvidia-settings --load-config-only not working

Running the nvidia-settings --load-config-only command and also adding it in the .xinitrc in the home directory does absolutely nothing. I’m able to apply the changes from the nvidia-settings gui and save to the xorg.conf but when i reboot it reverts back to something else, so i have to save it in the gui each time I boot.

This is also a duel boot machine with windows on the m.2 drive, and ubuntu on an external ssd.

Ubuntu version: 20.04
Nvidia version: 435.21
Nvidia-settings version: 440.64


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.64

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 435.21

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUS VG245"
    HorizSync       30.0 - 90.0
    VertRefresh     40.0 - 75.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce RTX 2080 Ti"

Section "Screen"

# Removed Option "metamodes" "HDMI-0: nvidia-auto-select +0+315, DP-0: nvidia-auto-select +1920+315, DP-5:    nvidia-auto-select +3840+0 {rotation=left}"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "HDMI-0: 1920x1080_75 +0+310, DP-0: 1920x1080_240 +1920+310, DP-5: nvidia-auto-select +3840+0 {rotation=left}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
1 Like

Did you ever find a solution to this?

any updates?

any updates??

Do you have the following directory on your system?


Here, I have this file in it:


with the following contents:

/usr/bin/nvidia-settings --load-config-only

And it works just fine. However, it’s important that the file is marked as executable, so do:

chmod +x /etc/X11/xinit/xinitrc.d/95-nvidia-settings