NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

Ok, good to know, so seems to be a general issue. Maybe try setting ‘nogpumanager’ kernel parameter just to test if that’s blocking start-up of the display-manager.

@generix
Thanks! That solved the Problem. Here the code that helped:

sudo dkms remove nvidia/460.39 --all
sudo dkms install --force nvidia/460.39 -k $(uname -r)
sudo update-initramfs -u
sync
reboot

all the best!

1 Like

@generix I tried “nogpumanager” same results. i.e. no splash, no desktop. I also tried out the @polomacnenad approach, again the same, no desktop. Finally, I just switched to my fedora machine for now. See if ubuntu manages to do a new update in the next few days!
Plz share here if you know more on this topic thanks a lot!

Hi @generix, I have the same issue. I have a Lenovo Ideapad which powered with an Nvidia GeForce and an Intel graphic card. The problem is when I install the Nvidia driver, the driver can not be recognized, and the out put of nvidia-smi shows, it can not communicate with driver. Everything seems to be correct and I can not see any error. I attached the nvidia-bag-report and the output of several commands in the following.
I will appreciate any help and command to solve this issue. Thank younvidia-bug-report.log.gz (107.3 KB)

gfuse@gfuse:~$ glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_MESA_query_renderer, GLX_MESA_swap_control, GLX_OML_swap_method,
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel® UHD Graphics 620 (KBL GT2)
GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
GL_IBM_multimode_draw_arrays, GL_INTEL_blackhole_render,
GL_NV_conditional_render, GL_NV_copy_image, GL_NV_depth_clamp,
GL_ARB_compute_variable_group_size, GL_ARB_conditional_render_inverted,
GL_INTEL_blackhole_render, GL_INTEL_performance_query,
GL_NV_compute_shader_derivatives, GL_NV_conditional_render,
GL_EXT_read_format_bgra, GL_EXT_render_snorm, GL_EXT_robustness,
GL_EXT_texture_view, GL_EXT_unpack_subimage, GL_INTEL_blackhole_render,
GL_NV_conditional_render, GL_NV_draw_buffers, GL_NV_fbo_color_attachments,
GL_OES_element_index_uint, GL_OES_fbo_render_mipmap,

gfuse@gfuse:~$ lspci -vnn | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation UHD Graphics 620 [8086:5917] (rev 07) (prog-if 00 [VGA controller])

gfuse@gfuse:~$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

gfuse@gfuse:~$ dkms status
nvidia, 460.56, 5.8.0-45-generic, x86_64: installed

gfuse@gfuse:~$ sudo dkms install nvidia/460.56 --all
[sudo] password for gfuse:
Module nvidia/460.56 already installed on kernel 5.8.0-45-generic/x86_64

gfuse@gfuse:~$ cc --version
cc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0
Copyright © 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

gfuse@gfuse:~$ inxi -G
Graphics: Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Device-2: NVIDIA GP108M [GeForce MX150] driver: nouveau v: kernel
Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa
resolution: 1920x1080~60Hz, 1920x1080~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.2.6

gfuse@gfuse:~$ lshw -numeric -C display
WARNING: you should run this program as super-user.
*-display
description: VGA compatible controller
product: UHD Graphics 620 [8086:5917]
vendor: Intel Corporation [8086]
physical id: 2
bus info: pci@0000:00:02.0
version: 07
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:128 memory:92000000-92ffffff memory:a0000000-afffffff ioport:5000(size=64) memory:c0000-dffff
*-display
description: 3D controller
product: GP108M [GeForce MX150] [10DE:1D10]
vendor: NVIDIA Corporation [10DE]
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: bus_master cap_list
configuration: driver=nouveau latency=0
resources: irq:129 memory:93000000-93ffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:4000(size=128)
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.

gfuse@gfuse:~$ sudo apt-get install nvidia-driver-460
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-driver-460 is already the newest version (460.56-0ubuntu0.20.04.1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gfuse@gfuse:~$ uname -r
5.8.0-45-generic

gfuse@gfuse:~ sudo apt-get install linux-headers-(uname -r)
Reading package lists… Done
Building dependency tree
Reading state information… Done
linux-headers-5.8.0-45-generic is already the newest version (5.8.0-45.51~20.04.1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gfuse@gfuse:~$ sudo apt install nvidia-prime
Reading package lists… Done
Building dependency tree
Reading state information… Done
nvidia-prime is already the newest version (0.8.16~0.20.04.1).
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

gfuse@gfuse:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Neon
Description: KDE neon User Edition 5.21
Release: 20.04
Codename: focal

Hello! I have the same problem , in fact when I first installed cuda it worked perfectly but later when I installed an app that works with cuda i get this problem , i tried a lot to figured it out but couldn’t so i reinstalled the OS(Kubuntu 20.04) and reinstalled cuda but I still have the same prob .Attached you can find the bug file, I hope you can help me. nvidia-bug-report.log.gz (70.9 KB)

Please try disabling secure boot in bios.

I still have the same prob

I just find a solution.
If your nvidia-smi failed to communicate but you’ve installed the driver so many times, check prime-select .

  1. Run prime-select query to get all possible options. You should see at least nvidia | intel .
  2. Choose prime-select nvidia .
  3. If it says nvidia is already selected , select a different one, e.g. prime-select intel , then switch back to nvidia prime-select nvidia
  4. Reboot and check nvidia-smi .
    from here I get it Ubuntu – NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running – iTecTec

Still having the same issue even after disabling secure boot. A new bug report has been attached. Thank you for your help. nvidia-bug-report.log.gz (210.5 KB)

@abir.bensoltane your solution does not work for me.

You now enabled nouveau, please blacklist it by setting kernel parameter nouveau.modeset=0

@generix thanks for your help, that solved my problem.

hi @generix .i tried every solution which is suggested in forum but this error still remains.i would appreciate your help.nvidia-bug-report.log.gz (191.1 KB)

$ nvidia-smi
“NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”

/////

$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 20.04.2 LTS
Release: 20.04
Codename: focal

/////
$ inxi -G

Graphics:
Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
v: kernel
Device-2: NVIDIA GM108M [GeForce 840M] driver: N/A
Display: x11 server: X.Org 1.20.9 driver: modesetting,nvidia
unloaded: fbdev,nouveau,vesa resolution: 1920x1080~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics 4600 (HSW GT2)
v: 4.5 Mesa 21.1.0-devel (git-5c8a7fa 2021-03-31 focal-oibaf-ppa)
///////

$ lshw -numeric -C display

WARNING: you should run this program as super-user.
*-display
description: VGA compatible controller
product: 4th Gen Core Processor Integrated Graphics Controller [8086:416]
vendor: Intel Corporation [8086]
physical id: 2
bus info: pci@0000:00:02.0
version: 06
width: 64 bits
clock: 33MHz
capabilities: vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:39 memory:f7400000-f77fffff memory:d0000000-dfffffff ioport:f000(size=64) memory:c0000-dffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
///////////////

[ 13.476188] bbswitch: disabling discrete graphics

You have bbswitch installed which disables the nvidia card. You don’t need it. Uninstall it.
I think the package is called bbswitch-dkms.

sudo apt purge bbswitch-dkms

1 Like

Thanks @Mart for your help. Error resolved.

Hello I also have the same problem.

“nvidia-smi” returns me also NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.
“nvidia-settings” gives also Errors: ERROR: NVIDIA driver is not loaded. ERROR: Unable to load info from any available system...

Strangely I don’t have any output for “ubuntu-drivers devices” and “lspci | grep -i nvidia”.Output of dpkg -l |grep nvidia-prime: ii nvidia-prime 0.8.16~0.20.04.1 all Tools to enable NVIDIA’s Prime
But dkms status: nvidia, 460.67, 5.8.0-48-generic, x86_64: installed

I have already deleted the file with 71-nvidia.rules at grep 10de /lib/udev/rules.d/* and changed GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=realloc" in /etc/default/grub, then updated grub and rebooted. But nothing has changed.

Computer: Linux ict-ThinkPad-X1-Carbon-7th
Ubuntu release: 20.04.1Kernel: 5.8.0-48-generic
Graphics: Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
Display: x11 server: X.Org 1.20.9 driver: i915 resolution: 1600x900~60Hz
OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.2.6
I have installed nvidia-driver-460.

The report file is attached.
Thank you for your help.
nvidia-bug-report.log.gz (187.2 KB)

There’s no trace of any nvidia device in your system, please check if it’s disabled in bios.

Thank you for your answer. How can I check it?

Enter bios:
https://pcsupport.lenovo.com/de/en/products/laptops-and-netbooks/thinkpad-x-series-laptops/thinkpad-x1-carbon-7th-gen-type-20r1-20r2/solutions/ht500222#1
and serch for graphics settings.

Also make sure your model really has a nvidia gpu built in.

Thank you, now I know the problem: my laptop doesn’t have nvidia gpu biult in :(