NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I have a similar issue.
nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I have tried several things in this thread but cannot find out what I am missing.

nvidia-bug-report.log.gz (119.1 KB)

I support a bunch of software developers using CentOS 7 on a Dell Optiplex 9020, and either an NVIDIA 510, NVIDIA 620, or NVIDIA 315 video card. I get this error every time there is a kernel update when I do a yum update. The vast majority of time all it takes to fix it is to rerun the NVIDIA video driver installation program.

@scott38 You have secure boot enabled, please disable it in bios.

Thanks. I thought I did but I guess I didn’t. It works now.

Hi,

Same prob… i want to use GPU for hash cracking.

I use a virtual machine (Kali linux x64 2021) running on a ESXi 7.0 Free with a PCIPassthru Enabled/Active, with a NVIDIA Corporation GF100 [GeForce GTX 480] that gets recognized by Kali, commands bellow.

What can i do to solved this? thks!

nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

uname -a
Linux kprs01 5.10.0-kali7-amd64 #1 SMP Debian 5.10.28-1kali1 (2021-04-12) x86_64 GNU/Linux

lspci | grep -i vga
00:0f.0 VGA compatible controller: VMware SVGA II Adapter
13:00.0 VGA compatible controller: NVIDIA Corporation GF100 [GeForce GTX 480] (rev a3)

lspci -s 13:00.0 -v
13:00.0 VGA compatible controller: NVIDIA Corporation GF100 [GeForce GTX 480] (rev a3) (prog-if 00 [VGA controller])
DeviceName: pciPassthru0
Subsystem: NVIDIA Corporation GF100 [GeForce GTX 480]
Physical Slot: 224
Flags: fast devsel, IRQ 9
Memory at fa000000 (32-bit, non-prefetchable) [disabled] [size=32M]
Memory at d8000000 (64-bit, prefetchable) [disabled] [size=128M]
Memory at e0000000 (64-bit, prefetchable) [disabled] [size=64M]
I/O ports at 6000 [disabled] [size=128]
Capabilities: [60] Power Management version 3
Capabilities: [68] MSI: Enable- Count=1/1 Maskable- 64bit+
Capabilities: [78] Express Endpoint, MSI 00
Capabilities: [b4] Vendor Specific Information: Len=14 <?>
Capabilities: [100] Virtual Channel
Capabilities: [128] Power Budgeting <?>
Capabilities: [600] Vendor Specific Information: ID=0001 Rev=1 Len=024 <?>
Kernel modules: nvidia

nvidia-settings
ERROR: NVIDIA driver is not loaded
ERROR: Unable to load info from any available system

dkms status
nvidia-current, 460.67, 5.10.0-kali6-amd64, x86_64: installed
nvidia-current, 460.67, 5.10.0-kali7-amd64, x86_64: installed

thks!

@voxhel Your Fermi gpu is only supported by the legacy 390 driver.

@generix Hello, I also have the same problem.

“nvidia-smi” returns me also NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running .
“nvidia-settings” gives also Errors: ERROR: NVIDIA driver is not loaded. ERROR: Unable to load info from any available system...

The output for “ubuntu-drivers devices” :
~ ubuntu-drivers devices
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C8Dsv0000103Csd0000838Fbc03sc00i00
vendor : NVIDIA Corporation
model : GP107M [GeForce GTX 1050 Mobile]
driver : nvidia-driver-450-server - distro non-free
driver : nvidia-driver-418-server - distro non-free
driver : nvidia-driver-390 - distro non-free
driver : nvidia-driver-460-server - distro non-free
driver : nvidia-driver-460 - third-party non-free recommended
driver : nvidia-driver-465 - third-party non-free
driver : xserver-xorg-video-nouveau - distro free builtin

The output for “lspci | grep -i nvidia”:
lspci | grep -i nvidia
01:00.0 VGA compatible controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Mobile] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev ff)

The output of dpkg -l |grep nvidia-prime: ii nvidia-prime 0.8.16~0.20.04.1 all Tools to enable NVIDIA’s Prime
But dkms status: nvidia, 465.27, 5.8.0-50-generic, x86_64: installed
nvidia, 465.27, 5.8.18-050818-generic, x86_64: installed

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=realloc" in /etc/default/grub, then updated grub and rebooted. But nothing has changed.

Computer: HP omen
Ubuntu release: 20.04.1 LTS Kernel: 5.8.0-50-generic

I have installed nvidia-driver-465.

nvidia-bug-report.log.gz (169.6 KB)
The report file is attached.
Thank you for your help.

Please check if you can manually load the driver
sudo modprobe nvidia
and post any errors shown.

The driver can’t be loaded, the error message is as follow:

modprobe: ERROR: …/libkmod/libkmod-module.c:838 kmod_module_insert_module() could not find module by name=‘off’
modprobe: ERROR: could not insert ‘off’: Unknown symbol in module, or unknown parameter (see dmesg)

It’s blacklisted and aliased to “off”. Please run
sudo prime-select nvidia
and reboot. Then check again.

After run ‘sudo prime-select nvidia’ (output: Info: the nvidia profile is already set), and reboot the pc, I check again, the driver still can not be loaded.

sudo modprobe nvidia
modprobe: ERROR: …/libkmod/libkmod-module.c:838 kmod_module_insert_module() could not find module by name=‘off’
modprobe: ERROR: could not insert ‘off’: Unknown symbol in module, or unknown parameter (see dmesg)

Please post the output of

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*
the output:

/etc/modprobe.d/blacklist-framebuffer.conf:blacklist nvidiafb
/lib/modprobe.d/blacklist-nvidia.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-drm
/lib/modprobe.d/blacklist-nvidia.conf:blacklist nvidia-modeset
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-drm off
/lib/modprobe.d/blacklist-nvidia.conf:alias nvidia-modeset off
/lib/modprobe.d/nvidia-kms.conf:# This file was generated by nvidia-prime
/lib/modprobe.d/nvidia-kms.conf:options nvidia-drm modeset=1

Please delete

/lib/modprobe.d/blacklist-nvidia.conf

then run
sudo update-initramfs -u
and reboot.

1 Like

I have the same problem on parrot os 4.11

Hi, I have the same problem. I am running Ubuntu 20.04.

Running nvidia-smi gives:

NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

nvidia-settings:
ERROR: NVIDIA driver is not loaded

ERROR: Unable to load info from any available system

(nvidia-settings:8243): GLib-GObject-CRITICAL **: 10:49:38.128: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed
** Message: 10:49:38.132: PRIME: No offloading required. Abort
** Message: 10:49:38.132: PRIME: is it supported? no

Attached is my bug report.
nvidia-bug-report.log.gz (129.0 KB)

Thanks in advance!

Fixed through:
apt update
apt upgrade

Then was showing that packages were being kept back, so followed the solution from here:
https://superuser.com/questions/1107334/apt-says-packages-have-been-kept-back-what-to-do/1108268

Also Having the same problem. The nvidia bug report is attached
nvidia-bug-report.log.gz (135.4 KB)

Some basic info of my set-up:
OS - RHEL 7.9
Kernel - 3.10.0
GCC - 4.8.5
GPU - NVIDIA GeForce RTX 2070 Mobile

Thanks in advance.