nvidia-smi: "No devices were found" despite a plugged Quadro P2000

One of our servers is running on Ubuntu 18.04.2, and has a Quadro P2000 installed.
Last available driver (430.26) has been correctly installed on it.



No devices were found

, while the Quadro is correctly detected by the OS

             description: VGA compatible controller
             product: GP106GL [Quadro P2000]
             vendor: NVIDIA Corporation
             physical id: 0
             bus info: pci@0000:b1:00.0
             version: a1
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
             configuration: driver=nvidia latency=0
             resources: iomemory:cff0-cfef iomemory:cff0-cfef irq:34 memory:f4000000-f4ffffff memory:cffe0000000-cffefffffff memory:cfff0000000-cfff1ffffff ioport:c000(size=128) memory:f5080000-f50fffff

I have tried to reset the gpu

nvidia-smi --reset-gpu

without any change.
I’ve noticed that the syslog shows a kernel error

kernel: NVRM: RmInitAdapter failed!

I’ve attached my nvidia bug report.

What do you advice to solve this problem?

nvidia-bug-report.log.gz (522 KB)

Looks like a hardware failure. Try reseating the card, check if it works in another system.

As said, I’ve already tried to reset the gpu based on

nvidia-smi --reset-gpu

It hasn’t changed anything. It is not easy to change the card because it’s on client’s side. Any idea before sending a technician? Thanks

reseAt, not reset. Hardware, not software. Probably broken.