Nvidia-smi not detecting devices, non-open driver not working at all

I have the nvidia-driver-525-open installed, but nvidia-smi returns ‘No devices were found’ and now I’m running on the integrated Intel CPU. I tried installing nvidia-driver-525 instead (without -open) and rebooted my laptop, but it would boot to a black screen. Hitting CTRL+F6 gives me a terminal where I can login. No idea what went wrong, so I removed 525, re-installed 525-open and now it boots to the intel cpu again. Any help?

Some extra information about my system:
Dell XPS15 7590
Geforce GTX 1650 mobile
Ubuntu 22.04

First time installing 525 failed halfway and “succeeded” when I tried again. However, the problem came up as described above. I went back to 525-open (again, as described above) and then tried installing 525 again. This time the install went flawless and everything works after reboot. So problem solved after all :)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.