Nvidia-smi shows "no devices were found"

I’m building a server (running Ubuntu server 20.04.2 LTS) and recently installed a Tesla M40 and Tesla K80. After installing the driver and running nvidia-smi, I get “no devices were found”
Originally, I installed the drivers by following the steps that can be found on this page: NVIDIA Driver Installation Quickstart Guide :: NVIDIA Tesla Documentation
That gave me the same error, so I tried again on a fresh install of ubuntu using the command line installation from this guide: How to install the NVIDIA drivers on Ubuntu 20.04 Focal Fossa Linux - LinuxConfig.org
After completing this, I still get “no devices were found”. I’ve tried disabling Nouveua and I have attempted to disable secure boot, but my bios doesn’t seem to have an option for it. Here is a link to the bug report: nvidia-bug-report.log.gz - Google Drive
If anyone could help me out with this it would be greatly appreciated. Thanks!

Please check the bios for an option to enable “above 4g decoding” or “large/64bit BARs” and enable it.
Disable CSM and reinstall Ubuntu using EFI-boot.

I can’t seem to find any of those options in my bios. I updated the bios just to be safe. Here are some pictures so you know what I’m looking at:
The advanced tab: IMG_7784.HEIC - Google Drive
Boot feature (in the advanced tab): IMG_7785.HEIC - Google Drive
PCI/PnP Configuration (also in advanced tab): IMG_7786.HEIC - Google Drive
These pages seem to be where the relevant options would be. The only options in the boot tab (not to be confused with the boot feature picture above) are boot device priority. The other tabs seem to lack relevant options as well.

Looks like this is an old non-efi board and there was a problem with 64-bit BARs on multi-socket systems so it has been disabled.
https://lkml.org/lkml/2017/12/6/750
So I guess you can’t use that board with Teslas.

Yep, looks like that person has the exact same motherboard. Next time I’ll do a little more research before throwing parts together :)