Nvidia-smi No devices found, Nvidia tesla M40 24gb

nvidia-bug-report.log.gz (97.9 KB)

I Installed the driver using the .run file, downloaded it from the link Data Center Driver for Linux x64 | 460.106.00 | Linux 64-bit | NVIDIA

The GPU is successfully detected by the system(Ubuntu 20.06):

mihlandota@mhdserver:~$ lsmod | grep -i nvidia
nvidia_drm             53248  0
nvidia_modeset       1228800  1 nvidia_drm
nvidia              34168832  1 nvidia_modeset
drm_kms_helper        184320  2 nvidia_drm,i915
drm                   495616  4 drm_kms_helper,nvidia_drm,i915
mihlandota@mhdserver:~$ lspci | grep -i nvidia
01:00.0 3D controller: NVIDIA Corporation GM200GL [Tesla M40] (rev a1)
mihlandota@mhdserver:~$ lspci -k | grep -EA2 'VGA|3D'
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
	DeviceName:  Onboard IGD
	Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
--
01:00.0 3D controller: NVIDIA Corporation GM200GL [Tesla M40] (rev a1)
	Subsystem: NVIDIA Corporation GM200GL [Tesla M40]
	Kernel driver in use: nvidia

But nvidia-smi gives me

mihlandota@mhdserver:~$ nvidia-smi
No devices were found

And nvidia-settings -q NvidiaDriverVersion gives me

mihlandota@mhdserver:~$ nvidia-settings -q NvidiaDriverVersion
Unable to init server: Could not connect: Connection refused

ERROR: The control display is undefined; please run `nvidia-settings --help` for usage information.

I will say in advance that I have Asus UEFI BIOS Utility 2.10.1208 (H81M-P Board). In the bios, I set the integrated GPU as a display GPU, since I need a server monitor. I also read that for GPUs with such volume of video memory as mine, you need to set the item “Above 4GB decoding” in the bios. But I don’t have this item. I found another item “Memory Remap”, which also had “above 4gb” written in the description, but I already had it enabled. Also note that my bios has been updated to the latest version and secure boot and CSM are disabled.

I no longer know how to solve this problem, I am grateful for any help

Hi, I’m having the same problem with my Tesla K40 card. Have you solved it?

Hi, yes, I solved this… after I completely changed half of the hardware of my server, including the motherboard. Therefore, if you do not have “Above 4G Decoding” in the BIOS settings, then congratulations, save up for a new motherboard where this setting will be!

Additionally, please make sure CSM is disabled in bios and the OS is installed in EFI mode.