Nvidia X server Xorg file disables second monitor option

I changed forced full composition option to checked to solve screen tearing problem. But if i change this setting, nvidia x server generates xorg.conf file and this file disables my second monitor. if i delete xorg and reboot everything solved without force composition. now attached xorg information is forced composition checked and second montior does not recognized. Asus is my external monitor and my built in monitor is hp pavilion 1bv33ea laptops monitor -> this goes right after creating xconf. So how can i add my other monitor to this xorg file manually with forced compositon on option for both displays?

OS: Ubuntu 20.04
GPU: GTX960m + intel hd graphics 530
Displays: HP 1BV33EA Laptop + ASUS VP228

xrandr
Screen 0: minimum 8 x 8, current 3840 x 1080, maximum 16384 x 16384
HDMI-0 connected primary 1920x1080+1920+0 (normal left inverted right x axis y axis) 476mm x 268mm
eDP-1-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm

My xorg file i think there is no description for second display:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.82

Section "ServerLayout"
Identifier     "Layout0"
Screen      0  "Screen0" 0 0
InputDevice    "Keyboard0" "CoreKeyboard"
InputDevice    "Mouse0" "CorePointer"
Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
Load           "dbe"
Load           "extmod"
Load           "type1"
Load           "freetype"
Load           "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier     "Keyboard0"
Driver         "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "AUS ASUS VP228"
HorizSync       24.0 - 83.0
VertRefresh     48.0 - 75.0
Option         "DPMS"
EndSection

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "GeForce GTX 960M"
EndSection

Section "Screen"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "Stereo" "0"
Option         "nvidiaXineramaInfoOrder" "DFP-0"
Option         "metamodes" "1920x1080_75 +1920+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
Option         "SLI" "Off"
Option         "MultiGPU" "Off"
Option         "BaseMosaic" "off"
SubSection     "Display"
    Depth       24
EndSubSection
EndSection

Please delete your xorg.conf, it’s a hybrid graphics system.
To mitigate tearing on the internal screen, enable prime sync by setting kernel parameter
nvidia-drm.modeset=1

sorry no still same tearing issue continues. like exactly as shown in wiki : https://en.wikipedia.org/wiki/Screen_tearing

i tried GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nvidia-drm.modeset=1” but did not solved…

yes xorg file is already deleted.

but there is a modeset 0 option in the /usr/lib/modprobe.d/nvidia-kms.conf is that a problem or what i did above takes priority?
kms:

# This file was generated by nvidia-prime
# Set value to 1 to enable modesetting
options nvidia-drm modeset=0

also
sudo cat /sys/module/nvidia_drm/parameters/modeset
returns
Y

PS: Also realized that tearing happens in external monitor, i change the refresh rate from 74,99 to 60 Hz also (from settings in Ubuntu). My builtin screen is60 Hz display it works normally and i saw just a few tearing after test, however external display has too many constantly for moving objects.