Nvmassflashgen is not creating a bootable image with the 32.5 release

I am building an mfi tarball for the production Jetson Nano module on the DevKit with our own rootfs using nvmassflashgen.sh. On release 32.4.4 this worked without any problems. On release 32.5 u-boot is unable to find any partitions on the mmc device when it tries to boot linux.

Tegra210 (P3450-0000) # mmc info
Device: sdhci@700b0600
Manufacturer ID: 45
OEM: 100
Name: DG401
Bus Speed: 48000000
Mode: MMC High Speed (52MHz)
Rd Block Len: 512
MMC version 5.1
High Capacity: Yes
Capacity: 14.7 GiB
Bus Width: 8-bit
Erase Group Size: 512 KiB
HC WP Group Size: 8 MiB
User Capacity: 14.7 GiB WRREL
Boot Capacity: 4 MiB ENH
RPMB Capacity: 4 MiB ENH
Boot area 0 is not write protected
Boot area 1 is not write protected    
Tegra210 (P3450-0000) # mmc part

Partition Map for MMC device 0  --   Partition Type: EFI

Part    Start LBA       End LBA         Name
        Attributes
        Type GUID
        Partition GUID
Tegra210 (P3450-0000) #

hello merwin,

for reference, could you please share the steps in detail.
thanks

In Ubuntu 18.04.5 LTS I copy our own rootfs to the rootfs directory before typing:

sudo BOARDID=3448 BOARDSKU=0002 FAB=200 FUSELEVEL=fuselevel_nofuse ./nvmassflashgen.sh -x 0x21 -S 1500MiB jetson-nano-emmc mmcblk0p1

The mfi_jetson-nano-emmc.tbz2 file gets created without any errors.

When I put the mmc module on the developer kit in recovery mode and run the nvmflash.sh script the output on the serial console proceeds until it tries to mount the linux partition in u-boot and fails. All of this worked fine in the 32.4 release.

hello merwin,

are you referring to Setting Up Your File System to create a Linux host system?
BTW,
according to R32.5 release notes, u-boot has updated to version 2020.04 for Jetson Nano, Jetson TX2, and Jetson TX1 modules

I am not using the sample Ubuntu rootfs but building my own using buildroot.

hello merwin,

FYI,
the kernel is installed into the filesystem alongside the boot configuration file. The kernel partition contains U-Boot.

My problem is that none of the partitions are found by u-boot as shown by using the “mmc part” command.

hello merwin,

we’ve check with JetPack-4.5, we cannot reproduce this issue on Nano-eMMC.