NvOFCudaAPI Errors 7 on Ubuntu 18.04 with T4

NvOFCudaAPI Errors 7 on Ubuntu 18.04 with T4

Hi,
I experienced following issue with my T4 and Ubuntu 18.04. I really appreciate some help ASAP.
My problem is that Optical Flow SDK 1.1 relies on graphics driver 435.21 or more, but the latest T4 driver is only updated to 418.87. I ran sample and reported the following error:

$ ./AppOFCuda --input=../../../08-08-09316/image_0000%d.png --output=./
GPU in use: Tesla T4
Input file directory path : ../../../08-08-09316
Input file pattern : image_0000%d.png
NvOFCudaAPI : NvOFAPICreateInstanceCuda(NV_OF_API_VERSION, m_ofAPI.get())returned error 7 at /app/sf-argus/wjp/Optical_Flow_SDK_1.1.10/Samples/NvOF/NvOFCuda.cpp;34

Can any one give me some suggestions on what I should/can do, thanks a lot!

Here is my configuration:

  • CPU : Intel® Xeon® Silver 4114 CPU @ 2.20GHz
  • RAM : 32 GB
  • DISK : 1 TB SSD

Current Driver 418.87 (have tried some different drivers)
Cuda: 10.1 with cudnn
Ubuntu 18.04

Thanks

Some options:

  1. wait for a driver to be published for T4 that is 435.21 or later (I wouldn’t be able to advise when this will happen, it will likely happen within the next 6 months)

  2. Use the driver they link on the optical flow page:

https://www.nvidia.com/download/driverResults.aspx/150803/en-us

It should work on T4, even though T4 is not listed as supported.

  1. Acquire a supported (Turing GPU) product for that 435.21 driver

Note that the Optical Flow SDK has its own forum section:

https://devtalk.nvidia.com/default/board/244/video-codec-and-optical-flow-sdk/

I recommend asking OF SDK questions there.

Thanks Robert_Crovella!

The second option fixed my problem! Do as the following steps:
1: update my T4 driver to 435.21
2: install cuda10.1 again
3: reboot and rebuild app