nvprof -- cupta64_102.dll not found ??

I am new at cuda programming when I was trying to use nvprof command on command window I got cupta64_102.dll not found the error but when I google it I couldn’t find anything related to cupta64_102.dll… can someone explain the reason and solution?

even if I try to use just “nvprof” I got the same error

sorry, it is cupti64_102.dll

Program can bot execututed because cupti64_102 didn’t found. reinstalling the program may fix this problem

Okey I fixed the problem

For the benefit of anyone else the file is <CUDA_INSTALL_DIR>/extras/CUPTI/lib64 and I’ve just copied it to <CUDA_INSTALL_DIR>/bin (where nvprof is)

Out of interest how did you fix it? Did you do the same?

1 Like

I found cupti_64_102.dll file at <CUDA_INSTALL_DIR>/extras/CUPTI/lib64 and I copied it to windows/system32 but now I have a problem about nvprof —metrics branch_efficiency

  1. For Windows, Please add the corresponding folder to PATH variable:
    C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v10.2\extras\CUPTI\lib64
  2. Open a new cmd prompt, now please try: nvprof --help

-SKA

THIS worked wonders for me