NvvmSupportError: No supported GPU compute capabilities found

Hello all,

I am testing some sample CUDA functions to analyse the GPU performance of jetson Xavier NX device. Here is the code that I am executing in jupyterlab notebook.

import numpy as np
from numba import cuda

@cuda.jit
def add_gpu(x, out):
idx = cuda.grid(1)
out[idx] = x[idx] + 2
a = np.arange(10,dtype=np.float32)

d_a = cuda.to_device(a)

d_out = cuda.device_array_like(d_a)

nbr_block_per_grid = 2
nbr_thread_per_block = 5
add_gpu[nbr_block_per_grid, nbr_thread_per_block](d_a, d_out)

out = d_out.copy_to_host()

def add_cpu(x):
for i in range(x.size):
x[i]+=2
return x

%timeit add_gpu[nbr_block_per_grid, nbr_thread_per_block](d_a, d_out)

%timeit add_cpu(a)

This code worked fine when I tried in CUDA 10.2 but I upgraded the CUDA version from 10.2 to 11.2 recently. Then I tried to run the same code in 11.2 and now I am getting an error as below.

NvvmSupportError: No supported GPU compute capabilities found. Please check your cudatoolkit version matches your CUDA version.

This is the output that I got for “nvcc -V” command.

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2020 NVIDIA Corporation
Built on Mon_Nov_30_19:09:42_PST_2020
Cuda compilation tools, release 11.2, V11.2.67
Build cuda_11.2.r11.2/compiler.29373293_0

Is this error occurring because of the CUDA version upgrade? Any solution to overcome from this?
Appreciate if anyone can help on this.

Jetpack 4.6 had CUDA 10.2
Jetpack 5.0 has CUDA 11.4

There wasn’t any Jetson Jetpack software drop that included CUDA 11.2.

You have broken the software install on your Jetson. Please don’t ask further questions about it here. The correct forum is one of the Jetson forums corresponding to your device. I’ve already indicated this to you here.