Cannot run sample programs

Hi,
I am having some trouble getting the sample programs to run. When running matrixMul, I get a code 3 error in the cudaGetDeviceCount(&device_count) function, when running vectorAdd I get a “Failed to allocate device vector A (error code inatialization error)!”. Searching on the forum suggests rebooting, which I have done several times, and updating my driver, but my driver updater says everything is up to date.

I use the toolkit version 11.2.0, have a Quadro K1100M gpu with driver version 426.78 and use Visual Studios 2019. Windows 10.

Using toolkit version 10.1.105 and visual studios 2017 did work for some reason, I think my gpu did not support a new enough version of the driver, but not sure about that.

That’s a device with compute capability 3.0, which is no longer supported by CUDA 11.

1 Like

Thanks. Actually it working was a false positive. VectorAdd and DeviceQuery work, but MatrixMul gives a cudaErrorLaunchFailure = 719 error. Any idea what might be causing that?

CUDA 10.2 supports compute capability 3.0 per this table, and the latest matching driver package for that CUDA version should be version 440.

I don’t have a machine with CUDA 10 to actually try it. However, every CUDA installer should include a compatible driver that you can select for installation.

1 Like

It says it is incompatible when I try to install driver 440, but I have installed CUDA 10.1 because this table CUDA Compatibility :: GPU Deployment and Management Documentation says >= 418.39, so I figured it should work for 426.78, which I have installed. Should I downgrade further to CUDA 9.0? I really appreciate your help.

I have a Windows machine here with a CC 3.0 GPU on which I run CUDA 9.2 with driver 441.66 (so in the 440 driver family). My understanding is that this is the last driver with support for CC 3.0.

1 Like

Hm, I’ll try some more combinations of versions then.

With 9.2 the error turns into a code=4(cudaErrorLaunchFailure) “cudaEventSynchronize(stop)”. It can’t be the driver, because 426.78 is newer than CUDA 9.2. Or can you also have a driver that is too new? It is from june 2020. (392.63 is from january this year? That numbering makes no sense to me). Edit: nope, tried 392.63 and now I get an error that says the driver is too old.

Yes, as discussed above you can have a driver that is too new and no longer supports outdated hardware. The driver I have installed for my GPU with compute capability 3.0 is Windows version 441.66 dated December 6, 2019.

Generally speaking, the NVIDIA download page can guide you to the latest driver package suitable for your GPU if you provide it with all specifics. That is how I found this driver for the Quadro K420 in this system.

1 Like

Do you mean this website Download Drivers | NVIDIA ? I did, (with the Production Branch/Studio option), and it gives the currently installed one. I reinstalled to make sure, and still the same error.

That’s the correct page. When I plug in the data you provided in this thread, it points me at driver 426.78 for Windows 10. The notebook drivers seem to follow their own series separate from desktop drivers? And the Win10 drivers seem to be separate from the Win7 drivers (which makes sense once I think about it, WDDM 1.x driver model vs WDDM 2.x driver model). My system with the old Kepler GPU uses Win 7.

Anyhow, I am out of ideas. I don’t use notebooks, only under-the-desk workstations. And I cannot recall the last time I had an issue getting a CUDA version or NVIDIA driver package installed.

1 Like

426.78 is also what I have installed. A pity it is not solved, but thanks for your time anyway.