Online Documentation for old CUDA Versions

The online CUDA documentation makes it seem like one could access older versions of it, but when I try it always says access denied. Having a NVDIDIA account doesn’t seem to help…

You might want to mention the specific page or CUDA version you are trying to access. I just followed the links for the CUDA 9.2 documentation (https://docs.nvidia.com/cuda/archive/9.2/) and that seems to work without issues.

Ok this link works for me too. The problem seems to be that many links go to https://docs.nvidia.com/ (doesn’t work) instead of the right address… This one also wont work for me: https://docs.nvidia.com/cuda/archive/10.1/ (doesn’t work) I get there for example when going to https://developer.nvidia.com/cuda-toolkit-archive (works) and then clicking “online documentation” behind CUDA 10.1 (Feb. 2019).

So I guess the answer is that NVIDIA should fix their website, as there are many links on the website just giving you Access Denied.

After some further investigation 9.2 and the newest Version are the only two working…

After some further investigation 9.2 and the newest Version are the only two working…

The latest version is 11, so I tried a version that is neither 9.2 nor 11: https://docs.nvidia.com/cuda/archive/10.1/
This also works for me. For example, clicking on “Programming Guide” on that page then brings me to https://docs.nvidia.com/cuda/archive/10.1/cuda-c-programming-guide/index.html

From which country are you trying to access these pages? I am in California, so within the United States.

This is really weird. Now 10.1 works and averything else (including 11 and 9.2) is not working. I’m accessing it from Germany.

No idea why it seems to be working only intermittently for you. Could be issues with NVIDIA’s infrastructure, or a problem with the content delivery network (CDN) that is most likely used to serve this data around the world, or something to do with your system or browser. For reference: For my experiments I used Microsoft Edge on Win 7 Professional.

1 Like

I tried Firefox on Android and Firefox on Fedora (also disabled all addons). Now only 10.2 is working.

I’m sorry you’re having trouble. I’ve tried all of the archived CUDA docs pages, and they seem to work for me (California also). I also VPNed into Germany to try them, and they all seem fine there as well, so I’m guessing it might be a problem with your provider or network.

I will open a ticket with the people who run our CDN, but could you please try the following to help ensure the problem isn’t with your network:

  • Access the site from your phone, using the cellular data network.
  • If that works, access the site from your phone using the same network that your computer is on.
  • If that doesn’t work, try tethering your laptop to your phone and using the cellular network.

Thanks!

Fred

1 Like

First it seemed to work a lot better with the cellular network (both on the phone and when using the phone as hotspot). But even then it’s not 100%. For example I was able to open all docs other than the 9.2 one. But then when I checked again with my home network, it was the same result, so I’m not sure if it’s better or if it was because e.g. you accessed these sites beforehand. It seems to me that the sites become available to me, when there is also traffic from other people (outside Germany?).

Thanks for doing the diagnostics. I’m checking with our CDN folks to see if there are any known outages.

Fred

1 Like

"Access Denied
You don’t have permission to access “http://docs.nvidia.com/cuda/archive/9.2/” on this server.

Reference #18.3f751602.1598373932.42810973 "

Is what I get for reference.

EDIT: The URL shown in the text is not completely identical with the one I’m tryng to use: I’m using https

I should also add, that I don’t think that this issue is new. I remember having this issue at least months ago when trying to access older documentation. I actually created this NVIDIA account because I thought that maybe only people with an account could access documentation for older versions of CUDA. As the newest docs probably get most traffic (?) it might fit the observations.

@FredPatton The issue is still not solved. Anything new from the CDN folks?

It finally seems to work!