OpenCL v1.1 support in latest drivers New Drivers with OpenCL v1.1 support

The latest publicly available NVIDIA® drivers now include support for OpenCL v1.1 applications.

More information about NVIDIA OpenCL support on CUDA architecture GPUs and driver download instructions can be found at www.nvidia.com/opencl

Thanks. This is very good news after all the waiting.

Got a question though, is this also supposed to be the case on Linux, because I get the following:
CL_DEVICE_NAME: GeForce GTX 295
CL_DEVICE_VENDOR: NVIDIA Corporation
CL_DRIVER_VERSION: 280.13
CL_DEVICE_VERSION: OpenCL 1.0 CUDA

See my post over here. The GTX 295 is just SM13 (like the GTX 285), which is why the CL_DEVICE_VERSION says OpenCL 1.0 while CL_PLATFORM_VERSION and CL_DEVICE_OPENCL_C_VERSION should say OpenCL 1.1.

Thanks for the info. I just cross checked on a GTX 480 and a GTX 580 and the indeed report OpenCL 1.1. :)

I’m currently having problems with this new driver release… I have an OpenCL 1.0 program composed by several kernels that has run fine for a long time (since the first beta releases of OpenCL drivers) and that now, after the updating to the new 280.26 Windows drivers, doesn’t work anymore because the call to clBuildProgram() makes the entire process die with an “Invalid floating point operation” exception.

I tried to trace back what this compiler doesn’t like and I found that I can compile if I comment all the calls to write_imagef() and convert_uchar_sat(). Does any other user have the same problem?

Hi everyone,

I have read some stuff (in another thread) about GTX 560 not supporting OpenCL 1.1
I suppose the latest drivers fixed that … Or am I wrong ? Actually I might be interested in purchasing a 560 Ti or a 550 Ti. Can anyone confirm that OpenCL 1.1 is supported on these cards ?

Thanks in advance.

From a hardware perspective, the GTX 560 (Ti) always has and does support OpenCL 1.1. I was just that NVIDIA did not have (official) OpenCL 1.1 drivers for a long time. With the current 280.26 stable driver you’ll get OpenCL 1.1 on the 560 (that’s on Windows, on Linux it’s the 280.13 driver). However, I recommend using the 285.27 beta drivers as they fix this issue.

Ok thanks for your answer

[font=“Lucida Console”]Hello.

I use Blender for 3d modeling, and there is this new renderer called Cycles, it uses the GPU for rendering. When I try to render something, I get this message:

OpenCL: platform version 1.1 or later required, found 1.0

I have the 270.41.19 driver from nVidia, I know that there is a new version of the driver, but I want to know if there is a fix in there when I upgrade, I don’t really like upgrades, since they tend to break my system.[/font]

Assuming you’re using the Quadro FX 580 from your footer, according to this post that GPU only has Compute Capability 1.1. For OpenCL 1.1, you need the current driver and a GPU that has at least Compute Capability 2.0. See here for an overview of Compute Capabilities for NVIDIA GPUs.

Are you aware of any offical words about OpenCL 1.1 requiring Compute Capability 2.0? I just need something to show it to my boss before asking him to upgrade the hardware.

No, I don’t know of any official document listing the OpenCL 1.1 requirements for NVIDIA hardware. The closest thing to an official statement again is an answer from NVIDIA support that I’m quoting here, saying “This is 1.1 only for the SM 2x devices […]” (where SM 2x is synonymous to Compute Capability 2x).

One of the mandatory requirements for the device to support OpenCL 1.1 is to expose at least 32KB of local memory. So if GPU has only 16KB of on-chip local (shared) memory then the drivers’ developers have two options:

  1. Provide 32KB of local memory by emulating local memory with global one.

  2. Support OpenCL 1.0 only for the device. But it might support language feature set of OpenCL 1.1, check CL_DEVICE_OPENCL_C_VERSION.

Option 2 looks the best one and it seems it is the one implemented.

Amount of local (shared) memory per compute unit (multiprocessor):

  • Compute Capability < 2.0: 16KB

  • Compute Capability >= 2.0: 48KB

I installed the latest Nvidia drivers (280.13) for my GPU from:
Ubuntu-X Home
But I still get the same error message, maybe it’s like they say in the IRC chat rooms, “having the latest (drivers) is not always the best”. Perhaps because is a reverse engineiring driver from Ununtu? I have no idea what’s wrong, and I really need OpenCL 1.1 for rendering my 3D scenes in Blender.

Like I already mentioned in this post, your GPU (Quadro FX 580) does not support OpenCL 1.1, no matter what driver version you install.

It is really great that the offical drivers now support OpenCL 1.1. I’m now searching for the actual OpenCL 1.1 conformant documentation. Such as

OpenCL_Best_Practices_Guide_Nvidia.pdf

OpenCL_Programming_Guide_Nvidia.pdf

OpenCL_ProgrammingOverview_Nvidia.pdf

and so on. The only files I find are a little bit outdated, since the last update on them where in february 2011:

http://developer.nvi…g-documentation

So if Nvidia now offically support 1.1 where is the suitable documentation for developers for it?

Thanks,

DerGraue

ATTENTION!!

PERFORMANCE ABNORMAL for opencl 1.1 only! -> http://forums.nvidia.com/index.php?showtopic=213692

@ManuelG

you look my previous post - very important!!!

[b]ATTENTION !!! NO FUNCTIONING NVIDIA OPENCL 1.1

[/b]

http://forums.nvidia.com/index.php?showtopic=216198

The last drivers which do not have the bug are those which use llvm instead of nvvm (270.41.19)

UPDATE 22-NOV-2011, After filling a bug report, NVIDIA says they have fixed the bug and that it will be introduced in the next driver release. There will hopefully henceforth be a functional NVIDIA OpenCL 1.1 implementation.

NOTICE:

You must read my 2 previous posts!