OpenCV Won't load videos

I have compiled and installed (make install) OpenCV 2.4.9 on my Jetson TK1. Everything seemed to work normally, but when I tried to test the gpu/hog.cpp sample (after compiling it of course), the binary prompts an error which says it cannot load the image (video) file, which is an .avi format.
Please note that the video file is the default one which is included in OpenCV example code. I also tried to test the program with a mp4 file, but no luck. When I tried doing it with a JPEG image the program did work as expected.

After searching a bit and reading, I could guess it was a problem with FFmpeg. So, I compiled it from source and thought this would resolve the issue. But it didn’t.

Now I’m clueless; what am I missing here?
Thanks in advance,

please add argument --video while running your sample

Already tried it. Does not work

hello,friend. I am new on Jetson TK1 with OpenCV4Tegra installing.There is a problem blocking me. i have flashed the cuda6.5 as well as toolkit and downloaded the JetPack 1 with libopencv4tegra_2.4.9.1_armhf.deb and libopencv4tegra-dev_2.4.9.1_armhf.deb. When
i use dpkg -i to install them ,it shows dependency problems that libopencv4tegra depends on cuda-core-libs-6-0 and cuda-extra-libs-6-0 .So i can’t install opencv on Jetson Tk1. I noticed you had succeed in installing opencv without any problems. Would you pls give me some directions? appreciate much.

I compiled it from source. This means that I did not use OpenCV4Tegra but rather the normal OpenCV without the NVIDIA/NEON optimizations which OpenCV4Tegra has.

If you want to compile it too, you can follow this guide:
Before you compile, edit the file as it is written in the following link, otherwise the compilation will fail.

Good luck