openCV on on Jetson TK1: Dependency is not satisfiable: libopencv4tegra

I’m trying to install OpenCV4Tegra on Jetson TK1, from here:


But I’m getting an error, “Dependency is not satisfiable: libopencv4tegra”
I tried installing using both the Software Center and GDebi package installer, same error.
Does anyone have any advice on what I could try?
Thank you!

Try this from your home directory, assuming that you used Firefox or Mozilla to sing into the Developer Zone to download these packages:

cd Downloads
sudo dpkg -i libopencv4tegra_2.4.8.2_armhf.deb
sudo dpkg -i libopencv4tegra-dev_2.4.8.2_armhf.deb

It worked for me. My actions before trying this included installing the CUDA developer kit, which added some repositories to apt-get, and then I downloaded some packages suggested by the CUDA developer kit’s installer. If the dpkg -i doesn’t work for you, try re-installing the CUDA developer kit, and then try once again with the dpkg -i.

See also man dpkg. The Ubuntu Graphic Package Installers are mostly front-ends to apt-get which is mostly a front-end to dpkg. Hope that helps,

dpkg -i worked like a charm! Huge thanks! Reading man dpkg now…

That got me too. Is there a bug in the way the package was made? Thanks for the help.