OpenCV4.6.0 with CUDA JetPack 5.0.2 - build script - missing V4l2ucp

The usual, I searched a lot before posting here

Best way to install openCV with Cuda on Jetpack 5 (Xavier NX) : openCV for Tegra?

JEP/install_opencv4.6.0_Jetson.sh at master · AastaNV/JEP · GitHub

At least for me the install_opencv4.6.0_Jetson.sh script does not run because V4l2ucp seems no longer available at JetPack 5.0.2. ( Ubuntu 20.04).
I removed it from the script to enable the build.
Any idea what wont work with Ubuntu 20.04 OpenCV 4.6.0 CUDA accelerate if V4l2ucp is not available?

Thank you,
-Jack

Hi,
V4L2 is the camera interface.

V4l2ucp seems to be a graphical interface to modify the camera parameters (brightness, contrast, frame rate, …). See https://v4l2ucp.sourceforge.net/ and v4l2ucp download | SourceForge.net

So I would guess that the only thing you will miss will be this graphical interface (so if you connect a camera and want to play with parameters, you will have to do it from the code).
Worst case, it might somehow be used to control parameters from opencv, in which case you will have to use directly the v4l2 interface (lower level than the opencv functions).

Thank you.

I am a bit surprised people have not reported the build problem yet. And someone claimed it worked with JetPack5. Maybe the issue is with JetPack 5.0.2?
It seems a common OpenCV build script with the Jetsons. No problems with the previous JetPacks. It was dropped on the latest versions of Ubuntu for some reason.
Of course having OpenCV GPU accelerate provide with the JetPacks is another discussion.

Thanks again,
Jack

Hi @JackSilb, if it helps I have a build of OpenCV 4.5 (with CUDA) for JetPack 5 here: https://nvidia.box.com/shared/static/2hssa5g3v28ozvo3tc3qwxmn78yerca9.gz

I recall also needing to remove v4l2ucp as that package seemed to be removed from Ubuntu 20.04.

Thanks,
Once. I removed the v4l2ucp the script worked. I am in business. It is part of my class to build OpenCV from source ;-)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.