Optix 5.1 unkown error with sample code

I am absolutely new to the Optix framework. I downloaded the latest version 5.1 and used cmake to configure and make compile as mentioned in INSTALL-LINUX.txt (I am using Ubuntu 16.04). Then went on to run some sample executables in /build/bin, for all of them I am getting same error:

OptiX Error: 'Unknown error (Details: Function "RTresult _rtContextLaunch2D(RTcontext, unsigned int, RTsize, RTsize)" caught exception: Encountered a CUDA error:  returned (999): Unknown
	(0) () +0x711547
	(1) () +0x70f8fb
	(2) () +0x31ad12
	(3) () +0x31b310
	(4) () +0x31d88e
	(5) () +0x333a4b
	(6) () +0x1c5b7f
	(7) () +0x1c88eb
	(8) () +0x1c9557
	(9) () +0x17a69b
	(10) rtContextLaunch2D() +0x2b9
	(11) main() +0xc69
	(12) __libc_start_main() +0xf0
	(13) _start() +0x29


If I run

nvcc --version

the output is:

nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2016 NVIDIA Corporation
Built on Tue_Jan_10_13:22:03_CST_2017
Cuda compilation tools, release 8.0, V8.0.61

I have seen similar errors in this forum, most of them complain that they are not able to run sample codes, but the function which throwing the error is different from mine and none of them have a solution.

Thanks :)

My bad the default driver used for display way not nvidia driver, hence the error.