Orin DevKit driver problem

I am trying to install a capture card (cn312s) driver on an AGX Orin DevKit for my university graduation project. This driver works well on Orin DevKit but when I connect forge carrier board, I am encountering an error during the compilation of the driver. When I enter the command, the details of the error is below:

sudo insmod cn312s.ko
insmod: ERROR: could not insert module cn312s.ko: Invalid parameters
sudo modprobe cn312s
modprobe: ERROR: could not insert ‘cn312s’: Invalid argument

  The output of dmesg` command in the terminal and received output can be seen in the dmesg.txt file in 

dmesg.txt (3.4 KB)

Could you please explain what exactly is causing this error and how I can fix it?

I have gathered some info from the students who started this project and left it without solving it :| it’s link can be seen below

Driver installation problem with modprobe - Jetson & Embedded Systems / Jetson AGX Orin - NVIDIA Developer Forums

This info was not enough for us to solve at least I could not do it :|

Solving this problem is crucial for my graduation project, and I would be very happy if you could assist me with this.

I appreciate your help in advance.

Do you download the kernel source and build the cn312s.ko again.
What’s forge carrier board?

Reference to below doc for build kernel and kernel module.


I built cn312s.ko and I got the same error when building the ko. The problem actually starts when I’m building the driver.

Forge card is a carrier board designed for AGX Orin and helps to increase port interfaces.

Kernel is already downloaded and we tried these on the downloaded kernel.

What do you mean error when building the ko?

I’m getting this error when building the cn312s.ko.

I mean not only getting this error when trying to set it up.

Sorry for the late response, have you managed to get issue resolved or still need the support? Thanks

I still need support. I am actually having trouble with customizing my kernel for the forge carrier. The driver works in devkit but when I switch to forge carrier board, I can’t set it up.

Please reference to below topic.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.