AGX Orin Kernel Customization Problem Jetpack 5.1.2

I am a Applied Computer Science Student at HTWG Konstanz and also Part of a Formula Student Team

We are currently facing a issue with the Kernel of our AGX Orin Dev Kit (Jetpack 5.1.2, Jetson_35.4.1)

We are currently trying to compile a project and get the following problem:

I have seen this issue a lot here in the Forum, but always for different versions of Jetpack. Although I tried some of the solutions without success.


Is this a known issue for Jetpack 5.1.2 and is there a solution for this problem.

I also tried to completely compile the Kernel from scratch but for some Reason I can´t quite get it working, If I follow the instructions from: Kernel Customization
at some point it seams there are missing some Steps to further Proceed.)

Or Maybe I am just too New for fully understanding how it should be done.

Can someone give me some tipps and help me ?


Can you please try this one?


Yes I have tried this before. but where is the original located. because I have never found it on my System and do not know where it should be executed.

Also the Kernel Customization is not 100% clear about how to proceed if you compile directly on AGX Orin or on Host System. like in Step “To Build the Kernel” Bullet Point 5 where Linux_For_Tegra is referenced which is not available directly on AGX Orin.

Is there a more detailed Description of how to do that?

Sorry If I am missing something here but I am kind of helpless at the moment.


It’s available in the BSP package.

For the case of native compilation, Linux_for_Tegra/rootfs/ is equal to the root folder (/) on your Jetson device.


This means I have to download and extract the Driver Package (BSP) to the / directory of my AGX Orin and then build from there … ?

I mean the installation path for kernel image/modules is the root directory.
You can extract the BSP to anywhere you want.


In the Kernel Customization at Bulletpoint 6 I have to replace Linux_for_Tegra/kernel/dtb/ with a copy from kernel_out/arch/arm64/boot/dts/nvidia/ but where should /kernel/dtb then be located ? /boot/dtb ?

It’s /boot/dtb/.

This means the only Things I have to copy are the “Image” file and all the dtb files. What do I have to do with the “kernel_out” and the “modules_out” directory ?

I think that depends on what changes do you make to the kernel source.
You may also need to install kernel modules.
For example:

sudo make ARCH=arm64 O=$TEGRA_KERNEL_OUT modules_install INSTALL_MOD_PATH=<top>/Linux_for_Tegra/rootfs/


for me the only goal is too fix the Issue with:

I think I don’t need any further adaptations.

I did copy the Image and the dtb’s to the corresponding directory without a change.

One thing that made me a little bit suspicious. when using the it is creating the directory sources and when I use the Download from the website then it is called source.

Yeah, then that seems to be fine for you.

I don’t think that makes any difference. Maybe we just forget to align them in terms of naming.

Okay. I have built the Kernel copied the Image file, the dub’s and the modules to the /boot directory and restarted the Board. Everything seams fine but I still get the “drivers/video/Kconfig:27: can’t open file “drivers/video/tegra/Kconfig”” error

I have to miss something…

Well, OK…

I just checked, and looks like this config is inherited from kernel 4.9, which is used by L4T 32.x and JetPack 4; the driver is removed in kernel 5.10, but it’s corresponding config is still there.

I think it’s safe to simply remove this line:

source “drivers/video/tegra/Kconfig”

from kernel-5.10/drivers/video/Kconfig.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.