drivers/video/tegra/Kconfig does not exist & can't be created

Jetson AGX Orin Dev Kit 64g
Ubuntu 20.04.6 LTS ~ 64-bit
GNOME Version 3.36.8
Jetpack 5.1.2

I’m relatively new to Linux so I’m sure I’m overlooking something simple (and probably didn’t even post enough background info^), but I’m attempting to run a make file to create then install a module and I keep receiving the error:

make     -C /lib/modules/5.10.120-tegra/build     SUBDIRS= modules
make[1]: Entering directory '/usr/src/linux-headers-5.10.120-tegra-ubuntu20.04_aarch64/kernel-5.10'
  SYNC    include/config/auto.conf.cmd
drivers/video/Kconfig:27: can't open file "drivers/video/tegra/Kconfig"
make[3]: *** [scripts/kconfig/Makefile:71: syncconfig] Error 1
make[2]: *** [Makefile:633: syncconfig] Error 2
make[1]: *** [Makefile:742: include/config/auto.conf.cmd] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.10.120-tegra-ubuntu20.04_aarch64/kernel-5.10'
make: *** [Makefile:6: default] Error 2

I’ve tried the solution(s) posted on the forum(s), including the .source_sync.sh && nvbuild.sh post/topic, but to no avail. I’ve worked on this for two days trying everything and I’m finally pressing the help button - if anyone has any insight and/or solutions, I would be greatly appreciative, or if anyone who is more experienced in Linux than me can hold my hand (so to speak) and help me troubleshoot, I’d also be very grateful. I’ve pretty much reached a dead-end and don’t know how to proceed.

Thank you any and everyone for reading this and for any time/help/support you’re able to offer. Looking forward to hopefully hearing back from someone.

  • Taylor

Hi,

What if you just copy the file from /kernel/nvidia/drivers/ to /kernel/kernel-5.10/drivers?

Or manually make the config file again:

None of those options ended up working/solving the issue - We appreciate you looking into this for us, though.

We were eventually able to get the module integrated, however. If anyone runs into issues using a Waveshare USB LTE module (ours is the SIM7600G-H 4G Dongle) on the Jetson AGX Orin, we were able to get it integrated by typing the following command into minicom:

AT+CUSBIDSWITCH=9011.1.1

No waveshare or simwwan drivers were needed.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.