Jetson AGX Orin --- Multimedia video controller

Hello,

Also when I run lspci command in terminal on my Jetson AGX Orin

0001:00:00.0 PCI bridge: NVIDIA Corporation Device 229e (rev a1)
0001:01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822CE 802.11ac PCIe Wireless Network Adapter

I can see them.

However,

Multimedia video controller: Intersil Techwell TW6816 multimedia video controller
I want to see above too.

Considering this document:

https://docs.nvidia.com/jetson/archives/r35.1/DeveloperGuide/text/SD/Kernel/KernelCustomization.html

To do this, I downloaded Driver Package (BSP) Sources in L4T 35.1.

/home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel/kernel-5.10

I tried to activate Multimedia video controller with make menuconfig in the above directory.
(device drivers/multimedia support/media drivers/media PCI adapters/Intersil Techwell TW686x video capture cards)
I tried to activate the above directory with make menuconfig.

I first tried this process on my AGX Orin device. I marked [*] like this. However,

Building kernel-5.10 sources
make: Entering directory ‘/home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel/kernel-5.10’
make[1]: Entering directory ‘/home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel_out’


*** The source tree is not clean, please run ‘make ARCH=arm64 mrproper’
*** in /home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel/kernel-5.10


make[1]: *** [/home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel/kernel-5.10/Makefile:577: outputmakefile] Error 1
make[1]: Leaving directory ‘/home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel_out’
make: *** [Makefile:213: __sub-make] Error 2
make: Leaving directory ‘/home/pc_2331/Downloads/public_sources/Linux_for_Tegra/source/public/kernel_src/kernel/kernel-5.10’

I got an error like above.
When I typed this command, the settings I made with the “make ARCH=arm64 mrproper” menuconfig were reset.

When I do this on my host device (x86 Ubuntu 20.04), Intersil Techwell TW686x video capture cards are marked as “M” by default.
If I try to mark it [*] like this,

“This feature depends on another which has been configured as a module. As a result, this feature will be built as a module.”
I am getting a result like this.

How can I solve this?
How do I enable “Intersil Techwell TW686x video capture cards”?

Hi,
Please check
Kernel Customization — Jetson Linux<br/>Developer Guide 34.1 documentation

For customizing kernel, you can enable the configs in

source/public/kernel/kernel-5.10/arch/arm64/configs/defconfig

And execute nvbuild.sh to build kernel. Not sure if the device can be enabled by enabling certain configs. If yes, it should work fin by doing these steps to rebuild kernel.

source/public/kernel/kernel-5.10/arch/arm64/configs/defconfig

I can not see configs about "Intersil Techwell TW686x video capture cards” in defconfig

Hi,
It seems to be this config:

kernel/kernel-5.10$ grep CONFIG_VIDEO_TW686X ./ -r
./drivers/media/pci/tw686x/Makefile:obj-$(CONFIG_VIDEO_TW686X) += tw686x.o
./drivers/media/pci/Makefile:obj-$(CONFIG_VIDEO_TW686X) += tw686x/

Please add it and give it a try.

./drivers/media/pci/tw686x/Makefile:obj-$(CONFIG_VIDEO_TW686X) += tw686x.o
./drivers/media/pci/Makefile:obj-$(CONFIG_VIDEO_TW686X) += tw686x/

I added above command to the makefile, compiled the kernel and flashed it with the SDK manager by making the necessary replacements.
However, I could not see “Intersil Techwell TW686x video capture cards” when I write lspci to terminal

I flashed it after I did the following part

Hi,
Please check if you can get help from vendor for enabling the device. The steps are correct and probably there is other missing configs or drivers. Need vendor or other users to share experience.

kernel/kernel-5.10$ grep CONFIG_VIDEO_TW686X ./ -r
./drivers/media/pci/tw686x/Makefile:obj-$(CONFIG_VIDEO_TW686X) += tw686x.o
./drivers/media/pci/Makefile:obj-$(CONFIG_VIDEO_TW686X) += tw686x/

Is above setting enough for that?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.