Orin MIDI ALSA disconnect

Hi i just got the Orin Nano dev kit , which runs software made for the previous Nano, so thanks for that.
Now i encountered an issue.
While on the old machinery my midi controler drove the software, on the new Orin nano however it does not.
Even a simple rawmidi dump to screen seems to work just one time , then if you start up again it just hangs.
How can i keep using my midicontroler for my home grown software ?
regards DO_Ray

Please check the troubleshooting section to see if can help: Audio Setup and Development — Jetson Linux Developer Guide documentation (nvidia.com)

It is not an Audio error it is an MIDI error, the curious thing is, it does work on the first time, so i don expect to see anything suspicious in dmesg. (i haven’t looked there yet).

Hi DO_Ray

Can you please share more details for me to understand the problem better?
What exactly is the use case and MIDI HW you are using? Please share some background.
What works in the first cycle?
Share error logs if you see any.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

MIDI programs function only one time
here is the requested dmesg, after the MIDI controller is plugged in :
[ 34.405928] audit: type=1326 audit(1687361292.234:4): auid=4294967295 uid=0 gid=0 ses=4294967295 subj=kernel pid=2463 comm=“cups-browsed” exe=“/snap/cups/952/sbin/cups-browsed” sig=0 arch=c00000b7 syscall=274 compat=0 ip=0xffffaa8188c4 code=0x50000
[ 122.263677] usb 1-2.1: new full-speed USB device number 7 using tegra-xusb
[ 125.847617] usb 1-2.1: new full-speed USB device number 8 using tegra-xusb
[ 125.954961] usb 1-2.1: New USB device found, idVendor=0547, idProduct=1974, bcdDevice=25.01
[ 125.954974] usb 1-2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 125.954979] usb 1-2.1: Product: VMXVJ1
[ 125.954983] usb 1-2.1: Manufacturer: CODANOVA
What you see is the moment i connect the midi controler, after i tried amidi -d (standard ALSA tool) first it functions properly, after i break it of with ^C (control C) it (amidi -d) refuses to function.
dmesg does not shows me more than this.
The reason i did not react to the first comments, is because i tried to solve this with an second computer with a LAN connected to ORIN, still i’d like to use the controller directly connected to ORIN.

Can someone take this up please? This is not an insignificant problem

Sorry for the late response, our team will do the investigation and provide suggestions soon. Thanks

Hi DO_Ray

If I understand the problem correctly, the MIDI controller you have is connected over USB interface and amidi command works fine for the first time. I believe the command fetches data from the external MIDI controller and dumps it.

Since the same controller is working for the previous nano kit, I would suspect if there is something wrong with amidi tool version or if something is going wrong during USB transactions. The logs don’t have much.

Do you know if your MIDI HW works fine on the same kernel and amidi tool version on any other host HW that presently Orin nano devkit has?

1 Like

Hi Spujar,
amidi version 1.2.2 on the ORIN NANO devboard.
uname -a
Linux -name- 5.10.104-tegra #1 SMP PREEMPT Sun Mar 19 07:55:28 PDT 2023 aarch64 aarch64 aarch64 GNU/Linux

I don’t understand your last request the MIDI HW works fine on a Jetson NANO , i will add the amidi version of that one later if you so wish.

you do understand the problem correctly

Okaye here is the data of my first Jetson Nano board:
amidi --version 1.1.3

uname -a
Linux -name- 4.9.337-tegra #1 SMP PREEMPT Thu Jun 8 21:19:14 PDT 2023 aarch64 aarch64 aarch64 GNU/Linux

Hi DO_Ray

Thanks for the details.

There are differences in the amidi version that you use on Jetson Nano and Orin Nano. This difference need to be ruled out first. Can you check if the newer amidi versions work better on any other host HW? Or you can try check older MIDI version on the Orin Nano.

i tried the older version on the ORIN it also did not work.

First i copied amidi to a folder on an USB stick , then i tried if this copy functions it did on the older NANO. then i copied this version to the ORIN.

This mean the tool itself is not an issue.
I think next step would be to check if this tool works fine on the newer kernels. This test can confirm if the issue is specific to Tegra setup or not. Is it possible for you check on any other system with similar kernel version?

Whoa i am still wet behind my ears (aka Newbie), how does one check the kernel version uname -a gives: 5.10.104-tegra #1 SMP PREEMPT Sun Mar 19 07:55:28 PDT 2023 aarch64 aarch64 aarch64 GNU/Linux. Do you imply i must check on another linux computer with the same kernel number which i guess that is 5.10.104 ?
Well for the in between solution which sends MIDI data through UDP to the ORIN. I use a Raspberry which has kernel 5.10.103. On that device amidi functions flawlessly. I hope this is your answer.

Well it all comes down to a bad instruction on how to activate the Orin Nano developerkit. Although there is mentioning of an image for an SD-card even Leela presents it. One must upload all through SDKmanager, which in the end, doesnot do what i expect it to do. I am convinced that when sdkmanager says it is ready that i can start and use the new developerkit, i even saw CUDA11 being installed. Well not so, through drudging through your datadungeon i discovered that Jetpack is not already installed by the sdkmanager, that makes al the difference. Now amidi functions as it should.

Please make the installation proces understandable, me for instance i don’t want deeplearning and openCV installed (yet) i just want to understand CUDA so now my small SDcard is filled with unnecessary stuff, thanks for your time


DO_Ray Good to know that you were able to resolve.

@kayccc please check on the feedback related to installation guide and if something can be improved there.

See i’d like to be off service here but you don’t give me a link to the installation guide of the Orin Nano developerkit, so that is exactly what went wrong here. Secondly a search with

installation guide orin nano

does not either