OSD text not working in multiple source regime

Plug-in ds-example modified to support multiple sources.
In single source mode OSD worked both text & rect ( both rect & text displayed)
In multiple source mode OSD worked only with rect ( only rect displayed)

Configuration:

[application]
enable-perf-measurement=1
perf-measurement-interval-sec=5
#gie-kitti-output-dir=streamscl

[tiled-display]
enable=1
rows=2
columns=2
width=1600
height=1200

[sink0]
enable=0
#Type - 1=FakeSink 2=EglSink 3=File 4=RTSPStreaming 5=Overlay
type=1
sync=1
#display-id=0
#offset-x=0
#offset-y=0
width=0
height=0
#overlay-id=1
source-id=0

[sink1]
enable=1
type=3
#1=mp4 2=mkv
container=1
#1=h264 2=h265 3=mpeg4

only SW mpeg4 is supported right now.

codec=3
sync=0
bitrate=1050000
output-file=./out.mp4
source-id=0
cuda-memory-type=1

[osd]
enable=1
border-width=1
text-size=25
text-color=1;1;1;1;
text-bg-color=0.3;0.3;0.3;1
font=Arial
show-clock=1
clock-x-offset=100
clock-y-offset=100
clock-text-size=12
clock-color=1;0;0;0
cuda-memory-type=1

[source0]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=2
uri=file:///mnt-ebs/input_videos/19-03-24_17-28-59_motion.h264
num-sources=1
cuda-memory-type=1

[source1]
enable=1
#Type - 1=CameraV4L2 2=URI 3=MultiURI
type=2
uri=file:///mnt-ebs/input_videos/19-03-24_17-29-39_motion.h264
num-sources=1
cuda-memory-type=1

[streammux]
##Boolean property to inform muxer that sources are live
live-source=0
batch-size=1
##time out in usec, to wait after the first buffer is available
##to push the batch even if the complete batch is not formed
batched-push-timeout=0

Set muxer output width and height

width=1280
height=720
gpu-id=0

0 - cuda pinned/host memory

1 - cuda device memory

2 - cuda unified memory

cuda-memory-type=1

[ds-example]
enable=1
processing-width=1280
processing-height=720
full-frame=1
unique-id=15
gpu-id=0

0 - cuda pinned/host memory

1 - cuda device memory

2 - cuda unified memory

cuda-memory-type=1

Can you try to set appCtx[0]->show_bbox_text = TRUE; in deepstream_app_main.c before g_main_loop_new

Thanks, it works