Packet loss after startup Ping network

TX2 passes through the switch. When it is started up, the Ping delay is large and there is packet loss. The packet loss disappears for a period of time. Is this normal? If it is normal, how long will it take to alleviate packet loss? If not normal, how should we solve it?

Please try to clarify the network environment and software environment when you file a post.

Also, please use devkit to reproduce the issue too.

Under “ifconfig”, which interface is it? For that interface, after you’ve had a period of loss and it starts working again, post the output of that interface’s “ifconfig” and also post the output of the “route” command.



ethtool -s eth0 speed 100 duplex full autoneg off
Solved the thank you linuxdev

Top contributor reply, above

Wayne WWW, I hope your reply is not so monotonous every time. If you use the latest suite and jetpack version every time, I won’t ask. Why do you answer my questions in the forum so carelessly every time?

Hi,

I am not sure what is the problem with you. If this is language problem, maybe you can just file you problem in Mandarin.
Every problem you filed so far does not have clear description. You should give clear description about your jetpack release version, log and the environment you are using. For example, network problem may come from different of your network. Why does this issue only happen to you but not reported everyday by other people? Haven’t you thought this might just happen to your switch?

You cannot just give a brief comment like “there is packet loss, what can I do?”. Your comment is monotonous every time and you expect other people to give you a detailed solution?

And here is the Mandarin version for you to read

首先, 我不知道你為什麼每次發文都只會講個一兩行然後貼一張圖片, 如果真的使用英文發問有問題的話麻煩你直接用中文發問
請你每次發文的時候基本上都附上你的jetapck資訊 跟log. 如果是網路相關的問題,麻煩你附上網路環境相關的資訊

我不知道你自己有沒有想過為何其他user都沒有回報過類似的問題, 是不是有可能因為這個問題只有你碰到? 如果只有你碰到 是不是跟你的那個switch有關?

你不能每次都給個一行文然後指望其他人能給你精準的答案, 我說明白一點, 你每次一開始給的資訊都不夠, 你怎麼期望我們能給出多豐富的解答給你?

And we already told you how to file topic 3 months ago. If you didn’t want to change, then please just expect us can only give such “monotonous” answer to you.

另外我們3個月之前就已經告訴你怎樣發文會比較好了, 如果你還是沒打算改的話 就請不要抱怨其他moderator給你的回答都如此制式化

好的,抱歉,因为我的理解是你应该相对于我来讲,对这个产品的细节掌握的就跟你看的书本一样,这个比喻不知道恰当不

如果你希望我們像查書本一樣解掉你的問題, 你一開始就要把所有環境跟log資料準備好
這裡幾千個用戶用的jetpack 版本跟底板都有機會不一樣.

有些用戶用最新的jetpack4.6, 有些還在用4.3.
有些問題可能jp4.6已經解了 但是jp4.3 沒有, 所以我們才得問你的jetpack版本 如果是jp4.6已經解掉的問題, 我們或許可以拿patch回舊的jetpack 用

拿網路的問題舉例, 有些用戶的底板上面額外還接了其他的網卡然後他們的問題可能是從那個網卡上來的, 如果是這種case 那就跟我們原本的driver無關

這些case全部都有可能發生
在我們看來你只說了 “TX2接一個switch, 然後一開始會有packet drop”.

基本上你完全沒有澄清到我上面任何問題, 我講白一點. linuxdev回答你的東西基本上就是一些基本的ubuntu網路指令
今天你只是剛好運氣好可以ethtool改一改之後就能動了

但說實話 你現在的方法在我看來比較像是workaround, 不是solution, 拿我這邊的TX2跟網路環境舉例好了 我可以 “ethtool -s eth0 speed 1000 duplex full autoneg on” 然後我也不會掉封包, 但是你的case看起來要降到100M然後 auto negotiate得關掉才能正常運作

你如果覺得這樣的設置你能接受, 我也ok 但在我看來還是有問題就是了

好的

那还有问题,jetson是自动获取千兆还是百兆?能固定死吗

待系统关机后,通过网线将Ubuntu工作站的网口与另一台PC相连,在PC的网络与共享中心的本地连接中,就可查看工作站网口的工作速度,如果设置正常,PC的本地连接网速应该为100Mbps。

當你用上面這個command 設定之後你就已經寫死在100M了. 那個autoneg就是 auto negotiation的意思…

有auto negotiation 的話 Jetson 網卡就會跟你的switch溝通要用1000/100/10 哪種.

但是这个关机以后就失效了
,需要让他无论以后怎么样都是百兆

jetson的配置和普通的ubuntu网络配置一样的话,可以写成脚本固定到系统里,哪怕我关机也是百兆网口就完美了

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.