PCI error on TX1 boards

Dear Community:

I’m trying to add an extender to the PCI slot and attach my network card via the extender.
here is the link to the extenders I purchased:
https://www.moddiy.com/products/Gold-Plated-Premium-PCI%2dE-4X-90-Degree-Right-Angle-Riser-Card.html

and here is the link to my network adapter:
https://www.startech.com/Networking-IO/Adapter-Cards/pci-express-10g-sfp-network-adapter-card~PEX10000SFP

Without the extender, I have no problem and I can detect, assign IP, and use the network cards. I have multipe nodes and only in one of them my network card works with the extender (partially with errors below). The other ones doesn’t work at all. I tried to add the extender that works on the nodes that doesn’t work and it still doesn’t work. I put the extender that doesn’t work on the other nodes, on the node that does work and it still works. So I concluded it must be related to the TX1 board not the extender.

Here is the error message I get on the only node that is working. I thought it’s a good place to chase the problem. I’d be thankful if you share your experties with me.

[  638.518446] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  638.570157] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  638.618923] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  638.626280] pcieport 0000:00:01.0: AER: Multiple Corrected error received: id=0010
[  638.626291] pcieport 0000:00:01.0: can't find device of ID0010
[  638.626298] pcieport 0000:00:01.0: AER: Multiple Corrected error received: id=0010
[  638.626308] pcieport 0000:00:01.0: can't find device of ID0010
[  638.629223] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  638.629239] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  638.641789] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  638.652643] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  638.690115] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  638.690130] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  638.702653] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  638.714718] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  638.856894] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  638.857090] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  638.908039] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  638.956997] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  638.964453] pcieport 0000:00:01.0: AER: Multiple Corrected error received: id=0010
[  638.964465] pcieport 0000:00:01.0: can't find device of ID0010
[  638.964471] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  638.964480] pcieport 0000:00:01.0: can't find device of ID0010
[  639.161833] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  639.162020] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  639.212903] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  639.262518] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  639.269908] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  639.269919] pcieport 0000:00:01.0: can't find device of ID0010
[  639.588505] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  639.588699] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  639.639874] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  639.689481] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  639.785122] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  639.785320] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  639.836060] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  639.885337] pcieport 0000:00:01.0:    [ 0] Receiver Error
[  639.941199] pcieport 0000:00:01.0: AER: Corrected error received: id=0010
[  639.941401] pcieport 0000:00:01.0: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=0008(Receiver ID)
[  639.992130] pcieport 0000:00:01.0:   device [10de:0fae] error status/mask=00000001/00002000
[  640.021235] pcieport 0000:00:01.0:    [ 0] Receiver Error

It looks like a signal quality issue. Signal quality is a bit like a radio antenna…the end sink and the transmission lines all have to work together. Even slight changes can make major differences.

One thing to always consider is grounding. Is your mounting bracket combination mounted solidly with proper grounding at all attachment points?