Permanently set MTU

Hi everyone,

I am trying to enable a MTU of 9000 on our Jetson Nano (JP 4.5.1). I can do so with:

“ifconfig eth0 mtu 9000”

However this is not kept after a reboot.
I can permanently set the MTU via the desktop environment, this is reboot save.

Is there a way to set the MTU permanently via the terminal?

I have already tried:
" sudo ifconfig eth0 down && sudo ifconfig eth0 mtu 1500 && sudo ifconfig eth0 up"

Thanks for your help.

Can I provide more information, to solve this issue?


I don’t know myself, but the topic is probably specific to Ubuntu 18.04 (which is what that JetPack release installs). I found this Google search was of interest, although I don’t know if it actually works:

One of the problems is that I don’t know which releases use NetworkManager versus other software. However, if it is NetworkManager, then the GUI app “nm-connection-editor” (plus the built in GUI config tools) have an MTU setting (if you don’t have “nm-connection-editor”, then “sudo apt-get install network-manager-gnome”).

Any Ubuntu 18.04 documentation probably applies.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.