PGF95 12.5.0 problem with "PGFIO/stdio: Disk quota exce

Hello all,
this problem was encountered in May when the PGI compiler on the system (a Cray Xe6) was updated from 12.1 to 12.2 I saw similar discussions on this forum and thought that the bug 18647 was the fix for it.
At that time the bug occurred at a line with a rewind (used to open a new file [!]).

Now we have 12.5.0 and still get :
PGFIO/stdio: Disk quota exceeded
PGFIO-F-/unformatted write/unit=9/error code returned by host stdio - 122.
File name = fort.9 unformatted, sequential access record = 68
In source file prog.f, at line number 95499

line 95499 is:
write(kunit) kfield

the quota has not been exceeded.

Where can I find the error code interpretation?

Hi Dr. Skids,

Where can I find the error code interpretation?

This error message is coming from the OS’s stdio run time. On my Ubuntu Linux system, the error codes can be found in the system header file “/usr/include/asm-generic/errno.h”. I don’t know where these error message codes would be on a Cray system.

Does the same error occur on a different system?

  • Mat

Hello Mat,
on the login node that include file is avalable (not sure about compute node) but it just shows that the PGFIO is reporting 122 as disk quota exceeded. EDQUOT is defined as 122.

Anyway I have not got latest version of PGI on any other system that is powerful enough to run that simulation. However, I suppose I could try create a toy proto-code to emulatet it.

I can roll back to earlier versions, 11.[6|7|9|10].0 and 12.[1|2|3|4|5].0 for comparisons. the default module loads 12.3.0 but the users of this code will automatically load 12.1 (some even stick to 11.9!).

I am debuggin with print statements now (!).

Mark

Thanks Mark. More details would be appreciated.

  • Mat