PGI 5.2

I format my pc then, install the PGI 5.2 (32bit)

I think all of the setting which I did before.

And excute the pgf90, then error message appear.

This is prompt “pgf90 -r8 -O -g -o dtform.e dtform.f”

/usr/bin/ld: /crtbegin.o: No such file: No such file or directory

What is the problem?


Can you try using gcc with simple hello world program? If gcc does not work , it’s probably OS installation is not completed.


Hi, Dear
What is “gcc with simple hello world program”?
How I check the installation and how to install?
And this is my install script below


export PATH
export MANPATH

pgf77 -V -c x.f
pgf90 -V -c x.f

export PGI=/PGI

export PGI=/PGI
export PATH=$PGI/linux86/5.2/bin:$PATH
export LM_LICENSE_FILE=$PGI/license.dat

Thank you


As PGI compilers relies on a system linker/assembler, I would like you to try writing a simple and short program and compiler with gcc to see if it compiles and run. If not, then the problem is with your incomplete installation of the OS.

For example,

% cat >
main () {
printf(“Hello World\n”);
% gcc main.c
% ./a.out

It should print “Hello World” on your screen.


My OS is Fedora 3.
I never take this problem during install several times.
I commnad that you descript, but error messae shows,

bash: syntax error near unexpected token ‘“Hello World\n”’

I tried to install the fedora3 for different type(personal, workstation, server)

It always shows same error message.

Thank you.

Hi choingju,

I am not sure what or how you did. What would Hello World be in bash shell?

Did you follow what I ask you to do? You must write a small program in C and print something such as hello world. Then compile using gcc.

If you still have a problem, please email directly so we can fix you problem right away.