Pip install TAO Toolkit CLI 4.0.1 hanging up on “No module named ‘tlt.entrypoint”

Hello. After I pip install nvidia-tao==4.0.1 to upgrade from 3.22.05 to 4.0.1, the Tao command showed the module error as the picture below.

Even I did pip3 install nvidia-tao --upgrade I still get the error message.

How could I do to deal with the problem ?

This is the original version of my Tao

Can you double check with TAO Toolkit Quick Start Guide - NVIDIA Docs ?

After I ran the command, the pod of nvidia-gpu-operator remains only three pods and did not support for GPU operation.

I think your latest comment is not related to this topic.
For original error, please check if you run below before running “pip install nvidia-tao==4.0.1”
$ pip3 install nvidia-pyindex

After I ran pip install nvidia-tao ==4.0.1, I ran bash quickstart_launcher.sh upgrade and pip3 install nvidia-tao --upgrade. Now the module error messages disappear.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.