I am debugging a sensor, there is a very strange phenomenon, help solve it.

Execute the following command to capture a raw image, it is fail.

v4l2-ctl --verbose --set-fmt-video=width=3840,height=2160,pixelformat=RG12 \
                --set-ctrl bypass_mode=0 --stream-mmap --stream-count=1 \
                --stream-to=camera.raw -d /dev/video0

Execute cat /sys/kernel/debug/tracing/trace,Showing the following error

kworker/0:1-7970  [000] ....   332.213679: rtcpu_vinotify_event: tstamp:10732726828 tag:ATOMP_FS channel:0x00 frame:132 vi_tstamp:10732726338 data:0x00000000
kworker/0:1-7970  [000] ....   332.213682: rtcpu_vinotify_event: tstamp:10732750235 tag:CHANSEL_PXL_SOF channel:0x00 frame:132 vi_tstamp:10732749782 data:0x00000001
kworker/0:1-7970  [000] ....   332.213685: rtcpu_vinotify_event: tstamp:10732750853 tag:CHANSEL_FAULT channel:0x00 frame:132 vi_tstamp:10732750386 data:0x00000100
kworker/0:1-7970  [000] ....   332.213687: rtcpu_vinotify_event: tstamp:10732751797 tag:CHANSEL_LOAD_FRAMED channel:0x01 frame:132 vi_tstamp:10732751067 data:0x08000000
kworker/0:1-7970  [000] ....   332.213690: rtcpu_vinotify_event: tstamp:10732752069 tag:CHANSEL_FAULT_FE channel:0x01 frame:132 vi_tstamp:10732751068 data:0x00000001
kworker/0:1-7970  [000] ....   332.213692: rtcpu_vinotify_event: tstamp:10732752380 tag:ATOMP_FE channel:0x00 frame:132 vi_tstamp:10732751071 data:0x00000000

because of CHANSEL_FAULT data:0x00000100, I Can know the error of PIXEL_LONG_LINE

But both active_w and active_h are set correctly, it is the resolution of the sensor

Detailed dmesg and trace logs in the attachment

dmesg.txt (69 KB)
trace.txt (127 KB)

  1. Boost the vi/csi clock to try.
  2. Please have sensor driver to report more pixel of the width to try.
  1. Boost the vi/csi clock to try, the same error
    Execute the following command:
sudo su
echo 1 > /sys/kernel/debug/bpmp/debug/clk/vi/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/isp/mrq_rate_locked
echo 1 > /sys/kernel/debug/bpmp/debug/clk/nvcsi/mrq_rate_locked
cat /sys/kernel/debug/bpmp/debug/clk/vi/max_rate
cat /sys/kernel/debug/bpmp/debug/clk/isp/max_rate
cat /sys/kernel/debug/bpmp/debug/clk/nvcsi/max_rate
echo {$max_rate} > /sys/kernel/debug/bpmp/debug/clk/vi/rate
echo {$max_rate} > /sys/kernel/debug/bpmp/debug/clk/isp/rate
echo {$max_rate} > /sys/kernel/debug/bpmp/debug/clk/nvcsi/rate
  1. Please have sensor driver to report more pixel of the width to try , the same error
    in .dts:
action_w = "3864"