Primary laptop screen not working after changing the settings

Hey, so I’m using Ubuntu and running the newest Nvidia drivers. Since I have an external monitor I have to change the order of the monitors each time I ran Ubuntu, because for some reason the changes would all default after reboot. Anyway this time I decided to press the “Save to X Configuration File” button, so it would save.

Then everything was fine until I rebooted the system. After reboot the main laptop screen went dark and for some reason only the external monitor worked.

Here are some key things to note:

  • The main monitor works fine UNTIL I log into my Ubuntu account (type in the password and press log-in)
  • When the external monitor is plugged out, the main laptop screen will still be black.

nvidia-bug-report.log.gz (1.06 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Sorry I forgot about it. Its up.
Also, I’d like to add that the laptop screen doesnt go black, it just acts like its frozen with the second monitor working as it should. Its also not detected by X-Server.

It’s an Optimus notebook so the internal screen is connected to the intel integrated gpu. Please delete /etc/X11/xorg.conf and only use the monitor manager in the gnome control center to arrange monitors. Don’t use nvidia-settings.

Holly hell, it was that simple. Just renaming the xorg.conf to xorg.conf.old worked flawlessly. Rebooted and it was all correct. Went into settings and the monitor arrangement there! I knew it had something to do with the conf file but I had no clue that just deleting it would solve the issue.
Cheers!