Prime multi monitors for vr?

Main system

Soo, in “nvidia ondemand” and “intel powersave” i cqn keep green render status in steam vr rather easily. In xrand i also recieve the display(headset) is connected, as well as lsusb/lspci. It shows in non dirrct display in steam/on pc i recieve picture but my headset is blank. (Head set is hooked up to hdmi and linkbox). That is on ubuntu 21.04. Lsusb shows camers/base stations detected as well. Steam sees said base stations.

Secondary

My secondary pc when i tested the headset, same thing happened (both use same cpu/gpu) but the headset was picked up on that system when it uses 16.04. Note my 16.04 system has a bad hdmi port. Lsubs shows cameras and base stations detected. I have 2 drives in this. One on an nvme running 21.04 and a 16.04 ssd. The 21.04 here also didnt detect.

Both systems

  • 21.04 showed vive in lsusb.
  • headset + basestations detects in steam
  • shows like i should see what i see in pc in headset
  • “green render performance consistant graph” in intel mode
  • bios of both pcs/motherboards pre os (2 diffewnt motherboards same cpu same gpu) shows inside headset…

My theory based on this: in theory something in between driver 365.xx in 16.04 and 470.xx in 21.04 changed how multi monitor is handled and disabled it. So… how do i mKe my headset display on streaming pc? Note im using a vga for monitor one and hdmi for the headset.

Please create /etc/X11/xorg.conf.d/10-nvidia-hmd.conf

Section "OutputClass"
    Identifier     "Nvidia HMD"
    MatchDriver    "nvidia-drm"
    Driver         "nvidia"
    Option "AllowHMD" "yes"
EndSection

https://download.nvidia.com/XFree86/Linux-x86_64/460.67/README/xconfigoptions.html
The change was introduced in driver v378.

I’ll give it a shot, had no idea manual configuration was needed. You’re a life saver. Almost downgraded to older ubuntu version. Even xrandr wouldnt let me enable even the hmd tho was showing as detected.

Well i tried. My xorg.conf.d was empity before that

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

it could be a wayland issue. on xwayland i read

If you ran wayland, xrandr wouldn’t show connectors. You’re running an Xorg session.

nvidia-bug-report.log.gz (273.9 KB)

Would it be better if i ran a bug report while in the configuration i intend to run vr in/intel mode, and while its running? Well while everything works minus picture on my headset.

First of all, all connectors of that notebook are connected to the intel gpu, the nvidia gpu has none. So the config file doesn’t have any effect, just delete it.
In the logs, you are running the nvidia gpu as primary, the hmd on the intel is detected as “non-desktop”, you should be able to switch it using

xrandr --output HDMI-1-1 --set non-desktop 0

okay i typed that shows as connected in xrandr. i’m guessing i should set the intel to primary/restart pc to get picture?

i get this in intel mode. nvidia mode accepts the command but still no picture
Screenshot from 2022-04-19 10-22-31

Okay seams pre driver 378 works… asside from primary display being set wrong/to headset. Also it is somehow set to nvidia mode not intel.

Does

xrandr --output HDMI-1-1 --set non-desktop 0 && xrandr --auto

work in nvidia mode?

that gave me picture!

Well i got beatsaber on the actual headaet(more like display mirror at diffrent resolutions/merged displays) only steam vr gives error 307 in nvidia mode. Yet everything detects (minus basestations which i knew would be an odd case as not mounted) so im gonna have to do research to keep the tracking skip steam vr itself.

Thanks