Problem cloning image on Jetson TK1

Hi,

I’m trying to do a carbon copy of the system I configured on the Jetson TK1 so that I can flash it on other boards. I’m following the steps of the guide http://elinux.org/Jetson/Cloning but when I try to execute the command

sudo ./nvflash --read 12 system.img --bl ardbeg/fastboot.bin --go

the program prints “Nvflash 4.13.0000 started” and then it stuck.

Any hint in what could be the problem and how to solve it?
Many Thanks

This process is a long one, reading gigabytes bit by bit over USB2. Although it may seem stuck, how long did you wait? I suspect it was actually working…check the size of system.img, it needs to receive then reproduce the entire root file system.

If you want a log of the process:

sudo ./nvflash --read 12 system.img --bl ardbeg/fastboot.bin --go 2>&1 | tee clone_log.txt

Also, how much spare hard drive space is on your host?

EDIT: I just cloned and time required was 41 minutes. File produced is the exact size of bootloader/system.img.raw (for me 15 GB). It turns out that the log of the flash was 287 MB because of the constant display of bytes read, moment by moment.

Hi,

I tried it again this morning and it worked! I didn’t change anything so I don’t know what’s happened but I succeed. Thank you for your help.

Please make sure the DUT is under recovery mode before nvflash execution, Try “lsusb” command.
If the host can’t find recovery mode device, It will print “Nvflash 4.13.0000 started” and stuck.