Problem Regarding instalation PGI 10.3

Installation directory? [/opt/pgi]

Note: /opt/pgi seems to contain a previous installation.
This installation may fail to install files properly.
You may see messages from tar about file permissions, etc.

Installing software into /opt/pgi (this may take some time).
#############################
ERROR: file /lib/libc.so.6: not found.
ERROR: unknown glibc version (stable).

Making symbolic links in /opt/pgi/linux86/2010
/opt/pgi/linux86/2010/mpi is not a symbolic link.
No symbolic link is done.

Making symbolic links in /opt/pgi/linux86-64/2010


I am using ubuntu 18.04
I am facing problem in installation in 10.3, please help me this regard.

Hi Anuj_isro,

Given PGI 10.3 was released almost 10 years ago, it’s not unexpected that it would fail to install on Ubuntu version 18.04. The underlying system directories on Ubuntu have changed quite a bit since then and libc.so.6 is now located under “/lib/x86_64-linux-gnu”. While we can edit the makelocalrc script to find libc.so.6 in this directory, the glibc version is too new so is not compatible with this old version of PGI.

You’ll need to either install a Linux version from this (such as Ubuntu 9) or install a more modern version of PGI, such as 19.10, that supports Ubuntu 18.04.

-Mat