Problem with Google Chrome on Ubuntu + NVIDIA 470.82.00 + Wayland session

Hi, all seems fine for NVIDIA 470.82.00 on Ubuntu with GNOME 40.4.0 Shell running a Wayland session except:

Google Chrome 96.0.4664.45 (older versions suffered the same issue) does only show a black window. There is interaction possible, but it just does not show anything.

Even with all flags reset to default, the browser refuses to show anything. On an Xorg session there is no problem.

I get no errors but here is a screen capture:

Anyone else having this problem?

1 Like

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

nvidia-bug-report.log.gz (752.5 KB)

Please check if this helps:

Hi generix, indeed with the flags, the browser renders correctly. It still shows the libva error that I posted earlier (but that post seems held back by Akismet):

$ google-chrome --use-gl=desktop --enable-features=VaapiVideoDecoder
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[36699:36699:0103/] Passthrough is not supported, GL is desktop, ANGLE is 
[36657:36708:0103/] Checking Bluetooth availability started. Please report if there is no report that this ends.
[36657:36708:0103/] Checking Bluetooth availability ended.
[36657:36708:0103/] Checking default browser status started. Please report if there is no report that this ends.
[36657:36708:0103/] Checking default browser status ended.

In also noticed the google-chrome-unstable package does render okay without these flags.

So I suppose it’ll be up to the bowser devs to fix this?

I guess so, chrome is a bit behind regarding wayland/xwayland.

The weird thing is that with the 460 (or 465?) nvidia driver I did not witness this issue before… In fact, I saw much less issues and freezes in Wayland than with the 470 driver.

Anyway, thanks for following up :)

470 added support for Xwayland, previously it wasn’t working at all, so llvm software rendering was used. You didn’t have issues with the driver because you weren’t using it at all;)

Haha, that explains a lot :D