Program being profiled not exiting

I have a very odd problem. I was using Nsight Compute on Linux and it was working fine. Then I tried to add a custom section file, and things got sort of messed up. I deleted the installation and made a new one, although my old profiles and projects were still present in another folder.

Now everything works fine, except that for some reason when I run a profile, the program exits and the profile is created but the GUI stays stuck on “Profiling…”. At which point I must manually hit cancel and then go open the profile file manually.

Any suggestions? Any magic files I can delete outside my cuda install directory that maybe got corrupted?

Thank you,
Harris

Hi Harris,

there are no “magic” files. There are a few files like project and settings that you could try to remove, to see if that helps. You can find the location of the project files for each OS here: https://docs.nvidia.com/nsight-compute/NsightCompute/index.html#projects. You might want to remove both “.nsight-cuproj” and “.ncu-proj” files.

In addition, you would want to remove the settings file, which on Linux would be

(user)/.config/NVIDIA Corporation/NVIDIA Nsight Compute.ini

Last but not least, you could check if you have a profiler lock file at

/tmp/nsight-compute-lock
(see https://docs.nvidia.com/nsight-compute/ProfilingGuide/index.html#serialization)

You could also try to see if profiling using the command line interface directly works or not, to isolate the issue further.

Thank you Felix! After deleting all that and a reboot I’m back to working as usual.