PWM fan at maximum on shutdown


I am having a problem with the PWM fan operation on my jetson nano. After shutdown the fan runs at maximum speed continuously. I have to manually pull the power plug.

For additional info: The fan I have is one of the cheaper ones, but during normal running it seems to be controlled by the system well.

I run a custom Xubuntu 20.04 (community shared) rather than the official one.

What could be the problem ?

hello rreddy78,

did you means the fan still rotating at full speed even the system shutdown completely? (i.e. $ sudo shutdown)

Yes. That’s correct. The fan runs at maximum speed after a shutdown.

Looks like the pwm pins are set to 5V. I have a B01 hw. And I used the community shared custom Xubuntu 20.04 - don’t know if this has something to do with it

hello rreddy78,

could you please point-out the linkage for reference?
please also confirm this by flash JetPack release image via NVIDIA SDK Manager.

I have this flashed:

I will have to flash with latest image and see

hello rreddy78,

yes, please confirm with JetPack release image to narrow down the issue,
JetPack-4.5.1 is the latest production release, and supports all Jetson modules. you may install it through NVIDIA SDK Manager.

Yes, I can confirm that the problem is present with the latest JetPack-4.5.1 too. I flashed the latest Jetson Nano image to the sdcard and I can see the same behaviour on shutdown.

Please let me know if you need any other info like pin voltages or the images of the fan.

And btw, there is no problem with Suspend. So i will manage with Suspend option which was not available with the custom xubuntu image.

Hi rreddy78,

We can’t reproduce issue with JP-4.5.1 on Nano.
Please make sure your fan pins are connect correct.
You can reference this topic.

So now I checked the pins after shutdown with a multimeter and the value seem fine

I get 5.22V at Pin2
TACH is at 5V and PWM is at 0V.

So the problem can only be with the fan. It can happen only with the PWM and TACH are switched in the fan. But the wonder of it is that during normal running it works as expected.

Anyway I guess just have live with it and use Suspend. Thanks for your help.!